Kia Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
hi,new to forum,got problem with my o5 1.6.petrol cerato........been having intermittent starting problem for a while now.....took to garage and they checked it out and said its probably crankshaft sensor,which they replaced,but still no improvement....they then said it could be crank wheel?.........or maybe a fault with alarm/immobiliser.have booked it into another garage on the 18th nov 2010....has anyone any ideas,which would be very welcome....this is my second kia and i bought it from new......
 

·
Registered
Joined
·
49 Posts
Hi, does the immobiliser/key light come on dash with ignition on? worth checking that light everytime you start up, if it doesn't come on then engine won't start. immobilser unit (kia call it SMARTRA unit) common fault.
 

·
Registered
Joined
·
49 Posts
Need chassisnumber for actual price, done one on a picanto, same sort of fault, intermittent non start, when the immo light on dash didn't come on, car wouldn't start. should have a fault code also. unit was 95 pound plus fitting.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
thanks for that,yes it is the problem that you stated,sometimes light doesnt come on dashboard,but when it does come on it starts ok.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
apart from main dealer in milton keynes does anyone have any recommendations as to which garage would be best,i.e cost and competance.....many thanks in advance....
 
1 - 8 of 8 Posts
Top