Kia Owners Club Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Good Day,

I am having serious issues with my Carens, with a fault code that comes up saying Throttle position sensor switch faulty.

Obviously this is restricting the performance of the car.

I have had 2 garages one Kia to look at the issue, changed the throttle pedal at £160 with Kia, but still have the same problem.

Can anyone advise me what the possible issue might be an how I can get it resolved without anymore major expense.

Regards

Mick
 

·
Registered
Joined
·
2,027 Posts
Hi TALVISOTA

We're sorry to hear you're currently experiencing a
fault with your throttle position sensor.

Unfortunately without inspecting your Carens we'd be
unable to confirm what's causing the issue with your sensor switch. We'd
recommend getting back in contact with the dealer so they can carry out further
investigation on your car to see if the fault may be to do with something else
in your car.

Kia Customer Service

0333 2022990

Visitwww.kia.co.uk

Join inwww.facebook.com/kiamotorsuk

Enjoywww.youtube.com/kiamotorsuk

Follow us @KIAUK on twitter

Call centre opening hours:

Monday to Friday - 8:30am - 9pm

Saturday: 9am - 1pm

Sunday: Closed
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Hi, Thank you for your reply.

It was a Kia garage that supplied and fitted the throttle pedal via the diagnostic they reported...

I have since taken to an independent electric specialist whom also cannot identify the problem. They can clear the fault and once I restart the car an move off, it comes back on again.

The garage will not refund the money for the pedal assy and say they do not recognise another throttle sensor switch only the one incorporated in the pedal itself.

It seems to baffle everyone...

I am now having to run the car restricted until I can find someone who can point me in the right direction to what maybe causing the issue.

I am back with the original garage on Friday, for full service etc so will see what they can come up with then.

Best Regards

Mick
 

·
Registered
Joined
·
2,027 Posts
Hi Mick

Thanks for your reply.

It's great to hear your getting your car back in for
further investigations. Can you confirm if the original garage you're visiting
is a Kia dealer?

Kia Customer Service

0333 2022990

Visitwww.kia.co.uk

Join inwww.facebook.com/kiamotorsuk

Enjoywww.youtube.com/kiamotorsuk

Follow us @KIAUK on twitter

Call centre opening hours:

Monday to Friday - 8:30am - 9pm

Saturday: 9am - 1pm

Sunday: Closed
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
Hi,

I first took the car to my local garage not Kia... who ran the diagnostic to show the issue... They spoke to Kia [the electrical specialist] who sent the Throttle pedal assy to be fitted stating this included the sensor switch which the code was stating was the problem, no other switch is fitted on the vehicle he said.

On fitting and discovering the issue remained, the local garage contacted Kia again and informed them. They would not take the throttle pedal back, and offered to check my car themselves which they did. The electrical specialist checked it and ran the diagnostic, reset it and then immediately on restarting, the engine management light came on with the same code.

I am returning to the electrical engineer with Kia on Friday. Kia have informed him that no other switch is fitted, but have no idea what could be causing the error.. He will run a complete diagnostic and thinks it could be the ECU... so will see.

I hope this helps...

Mick
 

·
Registered
Joined
·
2,027 Posts
Hi Mick

Thanks for your post.<u1:p></u1:p>

Would
you be able to email us at[email protected]in regards to this case? Once your car is in a Kia garage we can start investigation on your case. Due to you
being such a new member to Owners Forum you currently do not have enough points
for us to be able to private message you.<u1:p></u1:p>

We'll
keep a look out for your email.<u1:p></u1:p>

Kia
Customer Service

0333 2022990<u1:p></u1:p>

Visitwww.kia.co.uk

Join inwww.facebook.com/kiamotorsuk

Enjoywww.youtube.com/kiamotorsuk

Follow us @KIAUK on twitter<u1:p></u1:p>

Call
centre opening hours:

Monday to Friday - 8:30am - 9pm

Saturday: 9am - 1pm

Sunday: Closed
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
Hi There,
As requested....
Well I can advise now after a full diagnostic check with my car, a new fault has occurred which says P2113 Throttle valve control system signal failure is the problem. I have had the throttle valve stripped cleaned and reset, and after 24 hrs the problem has returned. I have just been away which is why I have not replied sooner... and the acceleration and performance of the engine has now deteriorated even more....

After 2800 rpm I have no power at all, it does not operate in cruise control even on a small gradient, it jumps out... I have to go into 3rd gear to climb a small hill.

It was suggested the Turbo or the ECU is to blame.... I am not sure what to suggest now as I have already been charged £300 pounds and no final solution has been found.

I have a new throttle pedal and hrottle control cleaned but still have the issue. It seems the strip down and clean did something temporally but still is not fixed. I gather it is something to do with 2 engine cycles ....

I am hoping someone else out there has had similar issues and can tell me what maybe causing the problem.

Regards
Mick
 

·
Registered
Joined
·
2,027 Posts
Hi Mick

Thanks for your post.

We've found the case you have with Kia customer care and
we'll be taking this case over and will be in touch with the dealer you've been
directed to. Could you confirm which dealer this is? We'll work with them to
try and resolve the issue you're currently having with your Carens.

Kia Customer Service

0333 2022990

Visitwww.kia.co.uk

Join inwww.facebook.com/kiamotorsuk

Enjoywww.youtube.com/kiamotorsuk

Follow us @KIAUK on twitter

Call centre opening hours:

Monday to Friday - 8:30am - 9pm

Saturday: 9am - 1pm

Sunday: Closed
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
Hi,

Thank you for the message. I have since spoken with Kia Warwick, and will make arrangements in due course to book the car in for a full Diagnostic check with them to try to find the fault.

James I spoke to on 01926 493821.

He was not aware of the error message as such but should be able to narrow down with the diagnostic what and where the fault is..

Kind Regards

Michael
 

·
Registered
Joined
·
2,027 Posts
Hi Michael

Thanks for your post.

That's great to hear you're booked in for a diagnostic
check. If you do need any further assistance you know where to find us.

Kia Customer Service

0333 2022990

Visitwww.kia.co.uk

Join inwww.facebook.com/kiamotorsuk

Enjoywww.youtube.com/kiamotorsuk

Follow us @KIAUK on twitter

Call centre opening hours:

Monday to Friday - 8:30am - 9pm

Saturday: 9am - 1pm

Sunday: Closed
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
Hello Again,
So, still having on and off issues with throttle sensor code coming up and causing partial performance lock with the engine when it happens... reduced to 2800 rpm etc and it is very intermittent.

Diagnostic showed throttle position sensor fault. Had old unit cleaned and new unit fitted and still after a few days fault comes on again.

Took it back to electrician who feels the wiring loom to the sensor is faulty and need changing.

Can someone help with regards to identifying if the loom is separate or part of the main engine harness?

I am not going to purchase the whole harness if you can get the small independent loom separate.

Regards...
 

·
Registered
Joined
·
2,027 Posts
Hi Mick

We're sorry to learn you're still having intermittent
issues.

Please could you email your contact details and
registration to [email protected]
, making for the attention of TALVISOTA case owner.

We'll then try and get more information on the wiring
for you.

We look forward to hearing from you.



Kia Customer Service

0333 202 2990
 

·
Registered
Joined
·
3,523 Posts
you do not need to replace the whole harness, the throttle pedal will most likely have three wires going to it. even if it has more than that it does not matter just run some new wires from the sensor to the ecu, I would use some tow bar cable which is 5 core.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #14 ·
Hi Thanks for coming back... When the fault code first came up my mechanic ordered and fitted a new throttle pedal and switch assy but it never cured the fault.

It seems the throttle valve is the issue, which he removed cleaned and put back but found the loom or harness that connects to it was flimsy and loose. He could pull or push the wires within the connector and sometime it is fine and other times not. Sometimes the EML goes out on the Das and other times it comes back on.

He believes it is a dodgy cable or connector and it will need replacing but is it a separate loom or part of the engine harness?

Mick
 

·
Registered
Joined
·
1 Posts
Good Day,

I am having serious issues with my Carens, with a fault code that comes up saying Throttle position sensor switch faulty.

Obviously this is restricting the performance of the car.

I have had 2 garages one Kia to look at the issue, changed the throttle pedal at £160 with Kia, but still have the same problem.

Can anyone advise me what the possible issue might be an how I can get it resolved without anymore major expense.

Regards

Mick
I had this problem on 08 2.0 crdi. Replaced throttle body/pedal , fixed nothing.
Problem, after long investigation turned out to be worn cogs inside throttle body. Got a setvice kit from ebay.
Good Day,

I am having serious issues with my Carens, with a fault code that comes up saying Throttle position sensor switch faulty.

Obviously this is restricting the performance of the car.

I have had 2 garages one Kia to look at the issue, changed the throttle pedal at £160 with Kia, but still have the same problem.

Can anyone advise me what the possible issue might be an how I can get it resolved without anymore major expense.

Regards

Mick
I had same problem, replaced throttle pedal which has sensor on it. Did not fix problem, although that was what diagnostic suggested. Garages and mechanics couldn't help. Found problem myself looking at throttle body at front of engine. Turned out to be worn gears in throttle actuating mechanism. Got a service replacement kit on ebay for £30. Just had same problem, many thousands of miles later and this time I'm changing throttle body complete.
Hope that helps. You need to take throttle body off, be careful with electric clip, then take off top square cover over actuating mechanism , these are hex or tork screws. You'll see gears inside. Good luck👍🏽
 

·
Registered
Joined
·
3 Posts
I had this problem on 08 2.0 crdi. Replaced throttle body/pedal , fixed nothing.
Problem, after long investigation turned out to be worn cogs inside throttle body. Got a setvice kit from ebay.

I had same problem, replaced throttle pedal which has sensor on it. Did not fix problem, although that was what diagnostic suggested. Garages and mechanics couldn't help. Found problem myself looking at throttle body at front of engine. Turned out to be worn gears in throttle actuating mechanism. Got a service replacement kit on ebay for £30. Just had same problem, many thousands of miles later and this time I'm changing throttle body complete.
Hope that helps. You need to take throttle body off, be careful with electric clip, then take off top square cover over actuating mechanism , these are hex or tork screws. You'll see gears inside. Good luck👍🏽

Any chance of a picture or diagram showing where the throttle body lives on a 2008 2.0 diesel Carens mk2?
 
1 - 19 of 19 Posts
Top