Kia Owners Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
694 Posts
Discussion Starter #1
Yea I know, how random is that. Since new the ISG had rarely kicked in, not that I was that bothered and got used over these 4 years that it would just never meet whatever the criteria was. Today after a short motorway journey, 16 miles, then back through town roads and at every light the ISG kicked in. At first it threw me and I actually thought I had stalled the car! I have recently had the battery replaced so I can only believe that this is a factor. My January mileage was a little over 26 miles so not much driving time at all. Thought I post up as it is just unusual for it to actually work.
 

·
Registered
Joined
·
8 Posts
I have a 2019 Ceed since November and it hasn't worked once. Always get the orange A Arrow. I even asked for my Kia dealer to check it at its service in January, as that was when the 2nd year of the warranty was up, when they could have changed the battery. But they totally ignored it.

My wife's 20reg Sportage 1.6t works perfectly though...
 

·
Registered
2020 Sportage GT-Line CRDi
Joined
·
1,416 Posts
I have a 2019 Ceed since November and it hasn't worked once. Always get the orange A Arrow. I even asked for my Kia dealer to check it at its service in January, as that was when the 2nd year of the warranty was up, when they could have changed the battery. But they totally ignored it.

My wife's 20reg Sportage 1.6t works perfectly though...
I've has ISG on Vauxhall's and Kia's and it has rarely worked on either, frankly I don't worry about it. I think it is more effective on petrol engined cars than on diesels.
 

·
Registered
Joined
·
9 Posts
I connected my motorbike / car battery conditioner to my car overnight a few months ago and the ISG worked after that for quite a while, now the cold spell is here its rare for ISG to work, I reckon its totally down to battery condition and age, not to mention all the car variables that must be met before isg will work
 

·
Registered
Joined
·
694 Posts
Discussion Starter #5
I connected my motorbike / car battery conditioner to my car overnight a few months ago and the ISG worked after that for quite a while, now the cold spell is here its rare for ISG to work, I reckon its totally down to battery condition and age, not to mention all the car variables that must be met before isg will work
I just think it is magic, the first 3 months of ownership from new and the ISG rarely kicked in. This is happening now while it is still cold days. I'm tellin' ya its magic!! 🧙‍♀️
 

·
Registered
Joined
·
11 Posts
I just think it is magic, the first 3 months of ownership from new and the ISG rarely kicked in. This is happening now while it is still cold days. I'm tellin' ya its magic!! 🧙‍♀️
I recently bought a 2017 Sportage and the ISG has rarely kicked in. I drive 40 odd miles to work and back every week day and have seen the ISG work on only a handful of occasions, most of the time it doesn't work. At first I thought it was to do with the load on the battery (heated seats, heating, demister, etc) but there doesn't seem to be any logical explanation that I can see why it worked the times that it did and doesn't work on most occasions. I would be more bothered if this was a new car. it's going in for a service tomorrow so might bring it up.
 
1 - 6 of 6 Posts
Top