Kia Owners Club Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My ISG is driving me mad. When driving the light is off = isg on.
When stopping,out of gear,foot off clutch = light comes on = isg OFF.
Took her back to dealer, went on diagnostics...result after 3 days tests battery low and not holding charge. New battery.
6 days later...same problem. Now I have to wait 3 weeks until they can fit her in again to go on diagnostics.
Anyone else got this isg problem to hopefully give the garage some idea what to do
By the way she is only 9 months old.Ta very much.
 

·
Administrator
Joined
·
7,404 Posts
Hi gizzy
I can't help sorry as mines an auto but wish you well getting it sorted.

Welcome to the Venga gang gizzy. Some call us A-Vengas....some call us Vengarists....most call us mad


Enjoy the forum

PaulEdited by: Uvox2
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanx for taking the time Paul. I'm sure someone will shed some light soon. Think I might fit in well on this site as everyone keeps saying I'm mad anyway.
Happy motoring
Diane
 

·
Registered
Joined
·
4,539 Posts
Steady on! Mind you, when I first got my Venga, everyone called me Arsene - or something like that!
 

·
Administrator
Joined
·
7,404 Posts
And before anyone asks, no, I didn't play session guitar for The Vengaboys...thank heavens!

Anyway, back onto the topic, does anyone have any thoughts on the cause of the ISG question?

Paul
 

·
Registered
Joined
·
1,283 Posts
Jings, I had heard you played sessions for the Wombles and Smurff's, or was it the Smiths???.

If the ISG is giving as much pain as my back, I'd switch the system OFF.

Ian
 

·
Registered
Joined
·
166 Posts
Hello,

What type of journeys do you do? The reason I ask is because we got our 3 year old Venga in May, it had been with the Hyundai dealer for over a month on the forecourt. I drove it daily and did a 210 mile round trip and still the ISG didnt work. I had a chat at a dealers and they said that it just might not have got charged enough even though when my Hubby tested the voltage it read ok? The car had done 17k in those 3 years.

Did another long journey, the light then went off 50 or so miles later and it's worked just as it should ever since but I do do the 210 mile journey weekly so it gets a good run on the motorway and dual carriageways.

I know your car is newer and you've had a new battery but I just wanted to share my experience.
 

·
Registered
Joined
·
181 Posts
Don't forget that in the winter, if you have the heater fan blowing fast while the car is cold or other load such as heated window/seats then the ISG OFF light will automatically come on when you come to a standstill. I just have my climate control on "auto" and let the car decide if ISG will work or not.
However, just lately I have been switching the ISG off manually because I want the engine to keep warming-up even at a standstill.
 

·
Registered
Joined
·
90 Posts
Whenever I remember I turn the ISG off, I like to drive the car not the car drive me, I wish it could be dealer turned off

Barrie
 

·
Registered
Joined
·
170 Posts
It seems that there can be many different situations that disable the ISG facility;heavy electrical demand (headlights, fogs, A/C, rear window heater, high fan speed etc.) engine not up to normal operating temperature, frequent starting and stopping in queues - in fact anything that is temporarily causing the battery voltage to drop below a pre set figure. Kind regards to all. John.
 

·
Registered
Joined
·
90 Posts
This is how I understand the ISG operation

The pre conditions for ISG to work are as follows.



Coolant Temperature above 45 degrees Celsius

Vehicle speed under 5kmh

Vehicle in Neutral Clutch pedal released

Catalyst temperature above 200 degrees Celsius

ISG system turned on Battery above 80% charged

Brake Booster vacuum sufficient level

Battery temperature between 2 and 60 degrees Celsius

Vehicle speed has been above 10mph since start-up Seatbelt fastened Driver's door and bonnet closed.

When all of these are fulfilled - the ISG system will be active.


I think thats right

Barrie



Edited by: Barrie-h
 

·
Registered
Joined
·
488 Posts
I would have thought for safety reasons the handbrake should be on, but it's not.Mine goes for ages this time of year without it stopping, then I pull up and it stops.
Edited by: Chrispy1
 

·
Registered
Joined
·
3 Posts
Mines never worked in 8000 miles of ownership, not once! But I don't think night driving in the winter will allow the ISG criteria mentioned above to be fulfilled.
 

·
Registered
Joined
·
667 Posts
Thanx for taking the time Paul. I'm sure someone will shed some light soon. Think I might fit in well on this site as everyone keeps saying I'm mad anyway.
Happy motoring
Diane
No you are not mad. There is a long list of parameters that have to be right before it will work. But now it is too cold anyway. The battery charge must be sufficiently high, but is only charged UP on the overrun, otherwise in normal running it just replaces what is being used instantaneously. (theoretically the most efficient mode of operation) Also it won't work with the blower on or any heavy electrical load. It needs to know it will be able to restart.
There are many other threads on ISG.
Mine never worked unless I had charged the battery up on an AVG compatible charger. Many people turn it off anyway. Mine so rarely worked that I thought it had stalled when it did occasionally kick in.

There was a batch of duff batteries at one point and a problem of the steering not shutting down properly and draining the battery. #But of course your dealer will claim ignorance of this very well known problem.

On mine I threatened to fit a new battery and charge the dealer, that got his attention. He changed it under warranty. The correct new Varta AGM battery was about half the official Kia service cost. The system was very nervous and would oly let me play the radio for about two minutes before demanding I start the engine or it would turn the radio off.
 

·
Registered
Joined
·
13 Posts
Mine has worked once in 2 years of ownership (2015 1.4 petrol). It was in traffic on a very hot day back in Aug 2018. Never worked since
 
1 - 19 of 19 Posts
Top