Kia Owners Club Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hi, im a newbie so go easy with me.....

My family and i have justpurchaseda 53 plate sorento and we need dome advice on her please????

its the 2.5 auto diesel crdi xs model......

im finding that its very sluggish when you pounce out at a junction or at an island .....there is just no power there...then after a second or 2 its all there and the horses come out to play !

i found this also when i took it off the drive today also...i have to reverse off the drive so nose is pointing towards house so put it in reverse and there wasnothingthere...irevvedit but it was just about moving at a snails pace....it was like the clutch was being pressed but its an automatic....

can anyone help me on this?

Andy
 

·
Registered
Joined
·
1,677 Posts
I have no idea !!!!! - but welcome from me, and I hope the 'cleverer' chaps on here can assist you :)
 

·
Registered
Joined
·
4,988 Posts
Has the air filter been changed lately,i change mine every year regardless of mileage done.I have owned mine from new nowcomingup to 8 years,excellenttowcar
 

·
Registered
Joined
·
4,988 Posts
What is the colour of the auto fluid .If it has lost its red colour and gone dark brown it needs changing.
 

·
Registered
Joined
·
525 Posts
Welcome, Is it starting in 2nd and then kicking down to first?

Does it have a winter setting on the Gearbox, if it does it might start in 2nd...this ispurelya guess, i know Quite a lot of Auto's do this.....
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
Hi thanks for the bits of info there....

The fluid is a lovely red

i have not done the air filter yet

hmmm winter setting??? i know my vectra has this feature but cant see a button on the sorento
 

·
Registered
Joined
·
682 Posts
Hi Andy and welcome
Make sure the diesel fuel filter was fitted with a KIA make also the fuel pump filter could be block in the tank ?

See the Sorento section



Bob
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #8 ·
thanks for the replies. im still having same slow pull of problem, we went to devon it it few weeks ago and pulled our caravan like itwasn'tthere so the power is there just now when you pull off !
 
1 - 8 of 8 Posts
Top