Kia Owners Club Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
This panel under near side middle row of seats


Remove cover


Remove hoses and cable and unscrew bolts Philips or 8mm hex


As you lift the right side of sender rotate 1/4 turn to aid lifting out gently


The pick up gauze filter blocked with crud


Boris the spider in tank!


Filter removed ready for refit


Then reverse to re fit everything.

BEFORE YOU TRY STARTING THE ENGINE, PRIME SYSTEM USING THE BULB NEAR THE FUEL FILTER UNDER THE HOOD. A MUST.

Edited by: LOZ
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #5 ·
Hi Al
Good to hear from you again. It's the least i couild do knowing how frustrating it is to have this problem and KIA dealers not able to help because it doesn't have a fault code for this. Common sence does not prevail sometimes in dealerships.

The old bird is still going strong with several Spanish road trips now under its belt.
 

·
Registered
Joined
·
422 Posts
LOZ said:
Hi Al
Good to hear from you again. It's the least i couild do knowing how frustrating it is to have this problem and KIA dealers not able to help because it doesn't have a fault code for this. Common sence does not prevail sometimes in dealerships.

The old bird is still going strong with several Spanish road trips now under its belt.
Thats what it looks like on the filter -spanish flies - I'm having a problem with the EML coming on although the car is running fine - might try this and a fuel filter change - you never know!
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #7 ·
Most of the crud is from UK fuel
However, on a road trip i had EML come on shortly after a fill up. Next fill up light went out. Worth trying mate, when it does start cutting out the EML came on as well.

You can control EVERYTHING you put in your car EXCEPT the quality of fuel be it home or abroad.

I change my fuel filters every 10k regardless of what the factory tells me, be it KIA Merc, Audi and so on.
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #9 ·
Click up load or browse on photobucket.
It will open up your images or files to open images.

Click on one then hold down Crtl and keep down while you click on more images you want to up load. Once done press enter.

When you have them on Photobucket copy click on picture you want, i box will apear, click or copy the IMG code then paste into your post on here. If you have multi images Write what you want about image press enter for new line then paste IMG code under it. Photobucket is a bit slow so be patient.

If i can do it (normally i just shout at things until they start to work) then anyone can.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top