Kia Owners Club Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
any one know of any common problems with the high level brake light on the 03 shape? mines not working, cant find a dedicated fuse for it, lamp ok, no 12V at the holder, other brake lights fine.

will be starting to troubleshoot it this weekend.
 

·
Registered
Joined
·
702 Posts
timtheenchanteruk said:
any one know of any common problems with the high level brake light on the 03 shape? mines not working, cant find a dedicated fuse for it, lamp ok, no 12V at the holder, other brake lights fine.

will be starting to troubleshoot it this weekend.
Its not chaffed at the point where it comes out the body and into the tail gate is it ? Just had a look at the 2000 electrical manual and it takes power from the same feed as the lower brake lights, so unless they have chaged it the problem is between the lower ones and the hi level one
 

·
Registered
Joined
·
195 Posts
Discussion Starter #3
spot on, decided to have a look today, chaffed where the loom comes through, a few others were affected, so repaired and strengthened the protection with some garden hose (ok rough and ready, but it fits inside the exisiting rubber bit)

another note here too for reference, my high level was reverse polarity, ie it provided +12 to the outer of the lamp, rather than the base cap, discovered this whilst testing, glad I did, as I was fitting an led lamp in the high level as apposed to filament.
 
1 - 3 of 3 Posts
Top