Kia Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi all just wondering if anyone has had the same problem as me or can explain whats possibly happening with my 2003 Sorento V6.
When i start the car from cold all is fine, but what i cant understand is when the engine is up to normal running temperature i still dont get any hot air through the vents or windscreen de-mister vents, in fact its freezing. but if i incease the revs to say about 2500 rpm then hot air is produced, take my foot off so its back at idle and its freezing cold again, bit of a problem if i get stuck in a traffic jam as its -5 outside
.



Ihave checked the coolant level and it was quite low so i have filled that up but its not made any difference at all.



Thanks
 

·
Registered
Joined
·
2,252 Posts
If you can source the heater pipes have a feel at them they both should be about same temp. If one is hot and tuther is cold the heater matrix might be blocked.
Disconnect the hoses at the easiest point and give it a good flush in both directions with a garden hose.

Make sure heater control is at hot setting. I am not sure if there is water valve on this type of heater or its just a deflector plate.

After you've done that I would flush out the whole cooling system just in case there is a load of crud in it.

Have fun
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
will try the suggestions and let ya know of the outcome, praying its not the waterpump as im guessing that means access to the timing belt? ouch!!
 

·
Registered
Joined
·
6 Posts
I had similar problem with my V6 when I got her, caused by leaking coolant expansion tank. You fill it up and very slowly it looses coolant and as heater sits quite high all fluid runs away from it. The leaking expansion tank is comon fault in early Sorento . Heating system is excellent now though. Hope this may be of some help to you!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
thanks , will check the expansion tank soon as. hopefully its just a simple problem.
 
1 - 8 of 8 Posts
Top