Kia Owners Club Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi All, I have a 64 plate kia rio 3 1.4 petrol and im completely to blame here, decided to upgrade interior lights to led , bought some canbus free ones from eBay, fitted in boot, number plate, and front courtesy lights, all fine, working great.
went out and about, no issues, got back and decided to do rear passenger courtesy lights, and the car just went haywire immediately.
The computer has completely reset everything all settings, trip/fuel counters etc, and it seems to reset every time you turn the key, as I had auto aircon off, all of the lights on dash illuminating at a quarter of the brightness despite being on full brightness, front courtesy lights the same, boot open light...flickering like crazy
the needles do not do the usual dance on turning the key, and just judder and jump, and the key fob does not work, it won't open or lock the car and the little red light on fob just comes on when you press it! How can changing a bulb cause so much damage???????
I have put old bulbs in the courtesy lights, and the lights just dont work at all now. If anybody can help with some ideas, would be greatly appreciated.
Thanks in advance.....
 

·
Registered
Fusion white 2014 Proceed GT Tech
Joined
·
553 Posts
Wow, that sounds a nightmare! I don't really know enough about car electrics to advise you, but hopefully someone will be along soon who can.

But, my immediate thought would be to disconnect the battery for a few hours. If there's any chance something might need to reset in an ECU, that should do it. If you can, while it's off, check its state of charge; some of you symptoms might indicate a failing battery. It could just be a coincidence, or it could be one of your eBay bulbs has cause a catastrophic parasitic drain. Hopefully it's not some lasting damage to your circuitry.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
yes it is a nightmare gdh... lol, i cant believe how its caused this. Thankyou for your advice, something to definately try.
 

·
Registered
Joined
·
833 Posts
I would inspect the wiring around the rear light housing. Make sure you have not accidentally bent/dislodged a wire or tag that could be touching the car body.
 

·
Super Moderator
Joined
·
4,314 Posts
Have a read of the below thread.
Might shed some light on the issue....

 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Thats great ..thankyou iooi, it certainly seems an issue with that particulair light, I didnt remove the fitting though, just the bulb. I will check that fuse out tomorrow.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
I'm going to hope that as I pushed the new bulb in, I did use some force, I pushed the exposed positive fitting to touch the bare earth, causing the fuse to blow. Lets hope replacing the fuse will fix it, I will report back tomorrow
 

·
Registered
Joined
·
69 Posts
9383

Rio 2013 2 1.1crdi fitted nearly 2 years ago,luckily I had no issues with them.
9384

Done the DRL aswell LED few months ago.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Just wanted to update and thank everyone for their help regarding my issue. The culprit was a fuse in the internal fuse box, replaced it and all problems were rectified immediately and has been fine since.. I can't believe how one fuse caused so many issues! I would never have sorted this without your help, you guys have saved me a few quid on calling out an auto electrician, so massive thanks again.
@ Myshu It looks good, mine has already got the led DRL, brake lights, and indicators in mirror, so just wanted the interior LED too.
 

·
Super Moderator
Joined
·
4,314 Posts
Thanks for the update on the fix..
Will help other users. (y)
 
  • Like
Reactions: Andy140

·
Registered
Joined
·
6 Posts
Discussion Starter · #11 ·
Well no problem again thanks to you . You guys should set up a "buy me a coffee" page, would gladly donate a few squids, given the money your collective knowledge and info saved me!
 

·
Registered
Fusion white 2014 Proceed GT Tech
Joined
·
553 Posts
Glad you got it sorted, and with no harm done!
 
  • Like
Reactions: Andy140
1 - 12 of 12 Posts
Top