Kia Owners Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, could anyone tell me if we are doing something wrong?
I have bought my wife a new 1.6 d JBL sportage .
She loves the car but on two occasions the entire centre console has gone black.
Nothing working. Radio , heater controls, Sat Nav, phone, Nothing.
She has on both occasions returned to the car to find all is working again. She assures me that she is not touching any controls ? It just stops then restarts.....?
After the first occasion I checked that the software version was the correct one, which it was.
Now I guess I need to book it in with my local ( Not Supplying) Dealer.
Trouble is if its not doing it , I suspect they will not find a fault. its happened twice in three weeks.
Has anyone experienced a similar problem ?
Thanks.
 

·
Premium Member
Joined
·
41 Posts
There was a recent problem with JBL head units (as fitted on 'GT Line S' and 'JBL' models) intermittently losing audio – sometimes it worked and sometimes it didn’t. There was a TSB released about it involving a software update.

However, even when the audio wasn’t working, the screen/map etc remained on and working (just without any audio/sound).

It could be something easy such as a semi-loose power connection at the rear of the head unit, which sometimes connects and sometimes doesn’t?

I would get the dealer to check it out.
 

·
Super Moderator
2020 Sportage GT-Line CRDi
Joined
·
1,503 Posts
There is a long thread about a similar issue 'New Kia Sportage (MY21) Problems' There is an update mentioned in the thread and it appears to be specific to models with the JBL system. There is a thread where somebody mentions the service bulletin, try the search function in the header of the forum page.
 

·
Premium Member
Joined
·
41 Posts
The TSB Details for the JBL audio problem is:


TSB Ref: KCE20-92-V321-QLe
Revised AVN MY2021 update

Firmware Version needs to be V200720 or higher.
 

·
Registered
Joined
·
1 Posts
Hi, could anyone tell me if we are doing something wrong?
I have bought my wife a new 1.6 d JBL sportage .
She loves the car but on two occasions the entire centre console has gone black.
Nothing working. Radio , heater controls, Sat Nav, phone, Nothing.
She has on both occasions returned to the car to find all is working again. She assures me that she is not touching any controls ? It just stops then restarts.....?
After the first occasion I checked that the software version was the correct one, which it was.
Now I guess I need to book it in with my local ( Not Supplying) Dealer.
Trouble is if its not doing it , I suspect they will not find a fault. its happened twice in three weeks.
Has anyone experienced a similar problem ?
Thanks.
I have the same issue on my 2020 Sportage along with many issues with voice recognition! Sometimes the system understands and says it’s doing as you ask but nothing happens! This is very bad on the climate control which is supposed to be voice recognition enabled but does not always understand your commands. When it does, for example “FAN HIGHER” it replies it is setting the fan speed to “5”, however, nothing happens! This applies to all available commands for air con and climate control!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
The TSB Details for the JBL audio problem is:


TSB Ref: KCE20-92-V321-QLe
Revised AVN MY2021 update

Firmware Version needs to be V200720 or higher.

Thanks for your help. I have checked and the correct firmware is installed.

I spoke to my local dealer and they are going to take a look at it . Apparently there is a recall on my chassis number.

Mr D
 
1 - 6 of 6 Posts
Top