Kia Owners Club Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
Back again 2005 sorento front parking sensors not working i have found the box under pass side carpet traced 2 power wires up behind the glove box removed the glove box the 2 wires are hanging loose'
My question is were do these wires connect they look like they have been pulled out of something but no were near the switch on the dash any ideas thanks guys
 

·
Registered
Santa Fe auto Sorento auto gone
Joined
·
5,187 Posts
Not standard previous owner must have fitted. When I had mine I fitted some cisbo ones worked fine. I have also fitted them on my grandchildrens motors. They are less than £20 a kit still today
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #6 ·
Hi i believe they are not after mkt ones the rear ones for instance are wired into the loom there an actual kia switch in the dash that the drivers handbook states, its to switch the front on when needed the control box is under the floor next to another black box under a steel plate its as thow the floor is doubled skinned / hollow with these boxes inside.
I haven't took the switch out yet to check what wires are about but thank you again guys
 

·
Registered
Santa Fe auto Sorento auto gone
Joined
·
5,187 Posts
You will find parking sensor switches on Ebay for about £3.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #8 ·
Hello guys tested switch all ok connected the the power leads to a battery so independent to the car no response from the sensors in the bumper so suspect box is at fault
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top