Kia Owners Club Forum banner
1 - 20 of 48 Posts

·
Registered
Picanto 3 2021
Joined
·
51 Posts
Discussion Starter · #1 ·

Just bought a 2021 Picanto 3 and I am very disappointed with the AndroidAuto feature. I have a Galaxy S21, connected via the original OEM USB cable, and AndroidAuto is just terrible to use. The map shutters when moving, its like the entire UI is running at 1fps, clicking buttons also takes a while to respond. What could be wrong? I have downloaded a "AndroidAuto on phone" app, and AA runs just fine on my phone. The problem is definitely on the Kia Entertainment system. Is there anything i can do to improve the experience?
 

·
Registered
Joined
·
2,936 Posts
Is there anything i can do to improve the experience?
Welcome to the forum, 'yurividal'.

Is it possible to test another phone using that same cable? A family member or friend's phone with AA installed would perhaps rule in or rule out the cable you are using. Even an iPhone with Apple CarPlay would do the same job, providing that ACP is ticked in the preferences within the infotainment unit menus.

If you can't make headway, then a discussion with the selling dealer my be the pathway to having the fault corrected. A system update might help if the software is not the very latest, which it ought to be.

Whether the car is new or second-hand, the infotainment unit is guaranteed for 3 years so if the dealer can't fix it, a replacement may be provided FOC.
 

·
Registered
Joined
·
1,177 Posts
I have downloaded a "AndroidAuto on phone" app, and AA runs just fine on my phone. The problem is definitely on the Kia Entertainment system. Is there anything i can do to improve the experience?
I use a Samsung A71 which, I believe, is older than your S21 and Android Auto works just fine for me, even without the original cable, although I don't use it often. I found the Android Auto app was already installed on my phone from new, I didn't have to download anything. Is it possible you might have inadvertently downloaded the wrong app?

Sent from my iPad using Tapatalk
 

·
Super Moderator
Joined
·
9,389 Posts

Just bought a 2021 Picanto 3 and I am very disappointed with the AndroidAuto feature. I have a Galaxy S21, connected via the original OEM USB cable, and AndroidAuto is just terrible to use. The map shutters when moving, its like the entire UI is running at 1fps, clicking buttons also takes a while to respond. What could be wrong? I have downloaded a "AndroidAuto on phone" app, and AA runs just fine on my phone. The problem is definitely on the Kia Entertainment system. Is there anything i can do to improve the experience?
What version android does your phone run?
As from 10 up there is no need for the AA app as it is built into the O/S.

What is the phone signal like in your area?

Never had the issue you are showing, but that to me could be too much running in the background (maybe downloading updates etc) on the phone slowing it down.
 

·
Registered
Picanto 3 2021
Joined
·
51 Posts
Discussion Starter · #5 ·
To clarify: I didnt download any Android Auto. After i noticed the issue, i downloaded an app from google called "Android Auto for Phone Screens", which basically allows you to run AA on your phone screen, simulating a car. I used this just to test and make sure that the problem was NOT my device. AA ran just fine in this environment.
Yes, the S21 comes with AA built-in (its actually part of google play services). I am running the latest Android 11 from Samsung with OneUI 3.1
Original, brand-new USB-C to USB-A cable that came in the box with the phone (i didnt use it for anything else, since i use wireless charging at home).
I also tried my Wife's Galaxy S20, and the same thing happened. AA is SO LAGGY compared to the built-in navigation that comes with the car.
The phone signal in my area is just fine. I do have some blind spots in my building's car park, but, the laggyness happens regardless of where I am. It's just a slow UI experience. I'm gonna try to record a video of it, so that you guys can compare. My guess is that the car just has a slow processor on these systems
 

·
Super Moderator
Joined
·
9,389 Posts
Thanks for the detailed reply (y)

Given you have just got the car. I would be tempted to take the car back & see what the dealer (maybe service dept) have to say.
Having run AA on 3 cars for over 3 years & several phones. We have never had this issue. So it could be a head unit issue. If it was a slow processor I would expect in built nav to be the same.
Does using the other apps in AA also have the same issue? So you do not get streaming music etc. Or which app's are giving the issue?
Do you have a I-phone that you could try and see if that has the same issue?
 

·
Registered
Picanto 3 2021
Joined
·
51 Posts
Discussion Starter · #7 ·
It's the entire AA experience. Waze, Google Maps, Spotify, Whatsapp, even just scrolling through the AA icons is laggy. I don't have any iphones, but i do have an ipad. Ill try to see if that works for AppleCarplay and test it out.
 

·
Registered
Joined
·
2,936 Posts
After i noticed the issue, i downloaded an app from google called "Android Auto for Phone Screens", which basically allows you to run AA on your phone screen, simulating a car. I used this just to test and make sure that the problem was NOT my device. AA ran just fine in this environment.
Try another cable?
 

·
Registered
Picanto 3 2021
Joined
·
51 Posts
Discussion Starter · #9 ·
For context, this video shows how laggy it is. Please let me know if this is how it looks for you guys too. Maybe I just have a stricter definition of smoothness... I have already tried a different cable too. (My Wife's S20 charging cable).

 

·
Super Moderator
Joined
·
9,389 Posts

·
Registered
Picanto 3 2021
Joined
·
51 Posts
Discussion Starter · #15 ·
Ok. I managed to test with a non-samsung Android phone, and to my surprise it was a LOT faster, no lag or whatsoever. Now, I need to start figuring out what's up with my S21 and my wife's S20.
We are both running samsung's latest Android 11.
As usual, it's Samsungs fault, and I doubt they will fix anything....
 

·
Super Moderator
Joined
·
9,389 Posts

·
Registered
Picanto 3 2021
Joined
·
51 Posts
Discussion Starter · #17 ·
Seems a common problem



That might help.
Thanks. But the phone itself is not laggy at all. It's pretty snappy. Even simulating AA on the phone was pretty snappy. It's just when using AA on the car screen that the lag is there.
 

·
Registered
Joined
·
1,177 Posts
Ok. I managed to test with a non-samsung Android phone, and to my surprise it was a LOT faster, no lag or whatsoever. Now, I need to start figuring out what's up with my S21 and my wife's S20.
We are both running samsung's latest Android 11.
As usual, it's Samsungs fault, and I doubt they will fix anything....
I'm wondering if it's unique to the S21 as I run Android 11 on my Samsung A71 without any noticeable problem.


Sent from my iPad using Tapatalk
 
1 - 20 of 48 Posts
Top