Kia Owners Club Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Hi all,

I recently took delivery of an eNiro 4+, never having driven an EV, and without a test drive (not sure whether that makes me brave or stupid - your call)! These are my first impressions:

Positives:
  • It's good to drive
  • Smoothness compared to ICE cars
  • Plenty quick (and I'm told it's not really limited to 104mph)
  • Practical enough (the cable storage is a nice touch too)
  • Plenty of space in the back
  • The range is not so far from the manufacturer claim.
  • It looks just like a "normal" car
  • The cooling seats - I really thought I wouldn't like them, but I do
However, it does have some idiosyncrasies that irritate me (nothing that make me regret getting the car, but mostly things that could easily be fixed)
  • Android Auto only using 2/3 of the screen is irritating, but it wouldn't be so bad if you could have the battery info (or some other function) in the other 1/3rd.
  • I like having hold assist on - I really wish it would remember this when I start driving, rather than having to press the button every journey (when I realise it's creeping forward when I have stopped)
  • As above, but switching the lane assist function off
  • I found it quite difficult to find a truly comfortable driving position. The steering wheel doesn't come out far enough and the centre console is too low (it was height adjustable in my previous car)
  • Why not have OTA updates for the software and maps?
  • Why don't the rear windows have a 1-touch function?
  • Good grief it beeps a lot.
  • The DAB radio loses signal much more often than the one in my previous car. I don't listen to it that my (I usually listen to Audible) but I would finding it quite irritating if I did
  • The UVO app has some good functions, but it's badly designed and often can't connect to the car for no obvious reason - but it can in the underground car park at work
  • The manual that comes with it is really useful - if only as a monitor riser.
  • What the hell does VESS stand for? Vehicle Emits Stupid Sound?
All in all, a very good car though!
 

·
Super Moderator
Joined
·
9,472 Posts
However, it does have some idiosyncrasies that irritate me (nothing that make me regret getting the car, but mostly things that could easily be fixed)
  • Android Auto only using 2/3 of the screen is irritating, but it wouldn't be so bad if you could have the battery info (or some other function) in the other 1/3rd.
  • Latest update gives you that option. (scroll up or down)
  • [*]I like having hold assist on - I really wish it would remember this when I start driving, rather than having to press the button every journey (when I realise it's creeping forward when I have stopped)
    [*]
  • Your not alone, but soon becomes 2nd nature once you put seatbelt on
  • [*]As above, but switching the lane assist function off
    [*]
  • You get used to it after driving for a while.
  • [*]I found it quite difficult to find a truly comfortable driving position. The steering wheel doesn't come out far enough and the centre console is too low (it was height adjustable in my previous car)
    [*]
  • Bit tongue in cheek this. Move seat further forward, & drop it down a bit. Which is how I found getting the most comfortable position (not what you expect)
  • [*]Why not have OTA updates for the software and maps?
    [*]
  • This has been rumoured as a future update for UVO equipped cars. But no timescale.
  • [*]Why don't the rear windows have a 1-touch function?
    [*]
  • Safety, don't want kids doing things like that and getting stuck in windows, even though they do stop when hitting a object.
  • [*]Good grief it beeps a lot.
    [*]
  • Sure do, try putting seatbelt on before pressing start. Cuts a load out.
  • [*]The DAB radio loses signal much more often than the one in my previous car. I don't listen to it that my (I usually listen to Audible) but I would finding it quite irritating if I did
    [*]
  • A few have mentioned this, not had the issue but find the shark fin not as good as the old style ariels.
  • [*]The UVO app has some good functions, but it's badly designed and often can't connect to the car for no obvious reason - but it can in the underground car park at work
    [*]
  • Try pressing refresh (red circle with a white arrow in under bell icon top right) before any action and re-enter PIN. Seems to work. As it does not hold connection to car for long for obvious reasons.
  • [*]The manual that comes with it is really useful - if only as a monitor riser.
    [*]
  • I have read mine more to help other people here than my own usage.
  • [*]What the hell does VESS stand for? Vehicle Emits Stupid Sound?
    [*]
  • I could say RTM, but in the spirit of help Virtual Engine Sound System Something to warn stupid people that do not notice a moving car 🤦‍♂️ :eek:(y)
Good review.
Hope some of the above help (y)
All in all, a very good car though!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
  • Latest update gives you that option. (scroll up or down)
Let me guess - I have to pay the dealer for the latest version? Does anyone know what the latest version is? I have:
Software: DE_E_20.EUR.S5W_L.001.001.200923

I can bring the battery info onto the final 3rd of the screen when using one of the in-car function, but not when using Android Auto

Safety, don't want kids doing things like that and getting stuck in windows, even though they do stop when hitting a object.
As you point out, they stop anyway. It's a minor irritation, not the end of the world

Sure do, try putting seatbelt on before pressing start. Cuts a load out.
I'd figured that one out, but then there's the "system check" chime, the 2x speed camera chimes (one would be fine), the lane keep assist beep when you get within 30cm of a line, the seatbelt error chime when I dump something on the rear seats and it thinks someone is sat there..

Try pressing refresh (red circle with a white arrow in under bell icon top right) before any action and re-enter PIN. Seems to work. As it does not hold connection to car for long for obvious reasons.
Yes, I know - it's failing to connect either when the app is starting (it cannot connect to server) and also after successfully connecting to the server it can't find the car - even when trying to refresh (and other times its fine)

I have read mine more to help other people here than my own usage.
I could say RTM, but in the spirit of help Virtual Engine Sound System Something to warn stupid people that do not notice a moving car 🤦‍♂️ :eek:(y)
These were both a bit tongue in cheek, but I'm sticking with my definition of VESS! :)
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top