Kia Owners Club Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2015 Ceed. The infotainment system has started being very erratic with the Bluetooth connectivity to my phone. I haven't changed phone/settings etc. My phone always thinks it's connected but about 50% of the time the Bluetooth icon is not shown on the infotainment screen and pressing the Bluetooth menu button does nothing, and no calls/music connection.
Always connects when the Kia logo is displayed on screen when starting the engine, but this often doesn't happen. Any ideas?
(Dealer suggested getting latest software/map update but it's really difficult for me to get to a dealer and might not work)
 

·
Super Moderator
Joined
·
3,422 Posts
The first thing I would do is unpair the car and device and make sure both have removed the connection. Then remake the connection and see if that cures your problem.
 

·
Registered
Kia Ceed 2 Ecodynamics 1.6 CRDi 62 plate
Joined
·
202 Posts
My 2013 Ceed 2 will not connect Bluetooth if the infotainment system is set to media when I start the car. It has been this way from new. If the audio is set to radio there is no problem. It is OK to switch to media once the phone has connected. Not sure if this might explain your car's erratic behaviour.

Otherwise, maybe disconnect the battery for a few minutes and see if it helps reboot the system. It cured a weird central locking problem on my car. This causes no problems on my car other than having to reprogram the clock. Newer models might need a bit more attention to what needs resetting, or so I've read.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thanks both. No change sadly. Just very frustrating that's it's suddenly started not working when noting has been changed. It doesn't look like the firmware has ever been updated so I guess I have to find a way to get it to a dealer.
 

·
Super Moderator
Joined
·
9,448 Posts
Thanks both. No change sadly. Just very frustrating that's it's suddenly started not working when noting has been changed. It doesn't look like the firmware has ever been updated so I guess I have to find a way to get it to a dealer.
While it looks like nothing has changed. Has your phone done any updates?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Managed to do a software update. Bluetooth version gone from 3.1.5 to 3.2.2 and seems to have solved the problem. I don't understand the how and why but it seems sorted so it's a result. Thanks all for the advice.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top