Kia Owners Club Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
I can't find this one in the manual or online. IMG_20210311_104506_resized_20210311_105101458.jpg

It started yesterday, stays on the screen until a few seconds after starting to drive.

Many thanks
 

·
Registered
2020 Sportage GT-Line CRDi
Joined
·
1,435 Posts
Error on your parking sensors. Check the sensors are clean and free of muck. If it continues it will need a dealer visit.
 

·
Super Moderator
Joined
·
4,312 Posts
Best guess a problem with front sensors.
Might just need a clean
 

·
Registered
Joined
·
5,229 Posts
I would guess "Fault in parking sensor system"

You engage reverse which turns on the parking sensors. You drive off and at a certain (low) speed the parking sensors are turned off again so the warning goes away.

Does it come on every time you engage reverse? Does it come on if you turn on the parking sensors manually?
 

·
Registered
Joined
·
64 Posts
Discussion Starter #6
Appreciate the super fast responses!
Typically it was serviced at Kia last Friday 😕
 

·
Registered
Joined
·
64 Posts
Discussion Starter #7
Turnup - yes, as soon as reverse engaged so sensors makes perfect sense. Thanks for all help
 

·
Registered
Joined
·
2,232 Posts
Typically it was serviced at Kia last Friday
If they cleaned the car for you before you collected it from the dealership, some indiscriminate use of the high pressure lance could have caused a little water ingress in one of the front sensors. It may leak out again if you are lucky. Otherwise, KIA will replace under warranty.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #9
Thanks again for all replies. Took to Kia yesterday, they confirmed fault but after 40mins gave up and asked to re-book in for a day. Sounds like a bumper off job. Still, times like this I'm glad of the 7 year warranty!
 
1 - 10 of 10 Posts
Top