Kia Owners Club Forum banner
1 - 18 of 18 Posts

Registered
Joined
6 Posts
Discussion Starter · #1 ·
My 2020 eNiro has decided to stop connecting to the mobile data network. It hasn't had a data connection for the last week. That means that the car's online functions (including UNO) are not working :-(

Anyone know how to reset it or convince the car to reconnect to the mobile network? The user menu options don't seem to have any way to achieve it.
For bonus points, any idea what mobile network the Kias connect to?

Thanks!
 

Registered
Joined
6 Posts
Discussion Starter · #3 ·
I would contact dealer on this due to it being a new car and not wanting to mess anything up.
Yep. I started the process. Requires booking in etc etc. so wondered if anyone else had had a similar experience and knew a knack.

Second time in the dealership in the two months that I have had it! :(

Thanks anyway.
 

Registered
e-Niro 4+ 2020
Joined
27 Posts
My 2020 eNiro has decided to stop connecting to the mobile data network. It hasn't had a data connection for the last week. That means that the car's online functions (including UNO) are not working :-(

Anyone know how to reset it or convince the car to reconnect to the mobile network? The user menu options don't seem to have any way to achieve it.
For bonus points, any idea what mobile network the Kias connect to?

Thanks!
My e-Niro didn't connect at all when I first got it. They eventually discovered the sim card needed (re)activating, which had to be done from South Korea. This solved the problem.
 

Registered
Joined
6 Posts
Discussion Starter · #5 ·
Finally got this resolved, so though I'd document here in case anyone else has the same problem in the future.

As mentioned above, the car was not making a data connection to Kia Connected Services. This is, I believe, due to the car being parked at home for periods of time where there is no mobile signal. After a while the car refuses to connect to mobile data at all, even when moving to an area with good mobile coverage. When you don't get any connected services you don't have traffic updates, etc.

When in its 'broken' state the UVO+ icon looks like this permanently (note no bars filled in on the UVO+ signal strength) in the top right of the infotainment display:
9508


The fix is quite simple once you know :) There is a reset button on the console, near the volume knob, and you can press this with a pin to reset the infotainment system.
9509


While the system is on, press the recessed button. Once it has undergone a reset, the connected services work again! I presume I'll have to do this a few times once it refuses to connect again, but hey it is an easy fix so I can live with that. Now, when in mobile coverage I get a signal again and I get the "Live" icon back:
9510


Thanks to the internet for helping to teach me about that reset button, so I'm passing it forwards in the hope that it helps someone else :)
 

Registered
Joined
1 Posts
Had the same problem after a 30 hours boat trip on my Kia e-Soul model 2019. Found the reset button on a slightly different spot on the infotainment panel. You have to look very sharp to discover it, such a small button to push with a pin. But it worked wonderfully. Connection recovered and I can use UVO again. Thanks a lot Greenthenblue!
 

Registered
Niro hybrid 2022
Joined
48 Posts
I will have a Niro hybrid 4 , will that have a SIM? I was told by the dealer that it will only work with a mobile phone ... and piggyback on that
 

Super Moderator
Joined
9,472 Posts
I will have a Niro hybrid 4 , will that have a SIM? I was told by the dealer that it will only work with a mobile phone ... and piggyback on that
What year?

You need to have UVO on the head unit.
 

Super Moderator
Joined
9,472 Posts
So you have a built in Sim. Which we believe is a Vodafone based one.

If you ever lose data connection then it is a simple case of a reset as per #5 post (2nd picture) no settings are lost when doing that.
 

Registered
Joined
1 Posts
Finally got this resolved, so though I'd document here in case anyone else has the same problem in the future.

As mentioned above, the car was not making a data connection to Kia Connected Services. This is, I believe, due to the car being parked at home for periods of time where there is no mobile signal. After a while the car refuses to connect to mobile data at all, even when moving to an area with good mobile coverage. When you don't get any connected services you don't have traffic updates, etc.

When in its 'broken' state the UVO+ icon looks like this permanently (note no bars filled in on the UVO+ signal strength) in the top right of the infotainment display:
View attachment 9508

The fix is quite simple once you know :) There is a reset button on the console, near the volume knob, and you can press this with a pin to reset the infotainment system.
View attachment 9509

While the system is on, press the recessed button. Once it has undergone a reset, the connected services work again! I presume I'll have to do this a few times once it refuses to connect again, but hey it is an easy fix so I can live with that. Now, when in mobile coverage I get a signal again and I get the "Live" icon back:
View attachment 9510

Thanks to the internet for helping to teach me about that reset button, so I'm passing it forwards in the hope that it helps someone else :)
Thank you so much for this. My car hadn鈥檛 connected since 6.12! Problem now solved!
 

Registered
2021 Kia Xceed 4
Joined
4 Posts
Finally got this resolved, so though I'd document here in case anyone else has the same problem in the future.

As mentioned above, the car was not making a data connection to Kia Connected Services. This is, I believe, due to the car being parked at home for periods of time where there is no mobile signal. After a while the car refuses to connect to mobile data at all, even when moving to an area with good mobile coverage. When you don't get any connected services you don't have traffic updates, etc.

When in its 'broken' state the UVO+ icon looks like this permanently (note no bars filled in on the UVO+ signal strength) in the top right of the infotainment display:
View attachment 9508

The fix is quite simple once you know :) There is a reset button on the console, near the volume knob, and you can press this with a pin to reset the infotainment system.
View attachment 9509

While the system is on, press the recessed button. Once it has undergone a reset, the connected services work again! I presume I'll have to do this a few times once it refuses to connect again, but hey it is an easy fix so I can live with that. Now, when in mobile coverage I get a signal again and I get the "Live" icon back:
View attachment 9510

Thanks to the internet for helping to teach me about that reset button, so I'm passing it forwards in the hope that it helps someone else :)
Many thanks for posting this. Picked up an ex demonstrator Xceed from local dealer. No UVO,,, This post saved my sanity.! I had seen the reset hole (On the right side of the display on mine) but hadn't dared use it in case I lost all of the settings I had already input. This gave me the nerve to do it and yes... Quick reset, UVO connected with full strength signal; all other settings retained. Still waiting (48hrs) for a callback from the tech expert at the dealership to tell me what to do..!!
 

Super Moderator
Joined
9,472 Posts
Hi & Welcome.

Hope you are using the "Connect" App & not the old UVO (y)

 

Registered
2021 Kia Xceed 4
Joined
4 Posts
Hi & Welcome.

Hope you are using the "Connect" App & not the old UVO (y)

Certainly am... And loving the facility to sort out a route on the phone then 'send' it to the car. Not sure about the remote locking yet, but I like the way I get a notification that the car is unlocked if I walk away from it... Now looking forward to some trips with it...
 

Premium Member
Joined
2 Posts
Thank you ! Worked on 2020 SoulEV too. Has been refusing to communicate for the last week.

On the Soul :

Reset button to the left of the Hazard warning button :
Automotive lighting Camera lens Motor vehicle Automotive tire Automotive exterior


The Car has been updated from UVO to Kia Connect - so, "Kia" is now on signal strength icon.
Hood Automotive tire Vehicle Automotive lighting Motor vehicle
 
1 - 18 of 18 Posts
Top