Kia Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello again, I have a 1.6 diesel optima gtls. I've had the light on about 5 times in the last 1000 miles. It comes on after fast driving on motorway, after 150 miles last time (low ish rpm) OR fast country roads. It restricts the performance but If I switch off the engine it goes away.
Had it to dealer who said no error codes stored so could not do anything. Advice was to come in to dealers next time its on. This will be hard as it goes off when the engine is off.
I think it's most likely a sensor issue as if the filter was blocked or the regeneration wasn't happening the light would stay on?
Anyone else had any experience of this? Other than that I love the car.
Thanks in advance.
 

·
Registered
Joined
·
1,524 Posts
I think it's most likely a sensor issue as if the filter was blocked or the regeneration wasn't happening the light would stay on?
Hi 'ChrisGTS1980'. It is as difficult for forum members to identify the fault at distance as it is for a KIA dealer when a vehicle is presented but with no fault apparent.

We can speculate but that would be complete guesswork in the absence of information such as mileage, service history, purchased new or second-hand; from a KIA dealership or independent/private sale?

Your thought that it may be a sensor issue might well be right but there are other reasons why such a problem has manifested itself. It is even possible that it may never recur. Sadly, it is not easy to pinpoint the reason when no fault code has registered.

If the problem returns and you take the car back to a KIA dealer, they could at least perform a forced DPF regeneration and check electrical connections before dispatching you on your way again.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thanks. Although even if you knew that I purchased new and has only 6500 miles it wouldn't help in any diagnosis. I just wondered if anyone else had any similar experience.
 

·
Registered
Joined
·
1,524 Posts
All is well.
Thanks, 'ChrisGTS1980', for coming back to inform those interested readers of the remedy to your issue.

Presumably, at such a low mileage, the matter was dealt with under KIA's warranty and I'm guessing there must have been a fault with the original component? In any event, let's hope you have no further issue on that score and the car provides you with the same excellent service that other owners here enjoy.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
After many visits and dpf lights it eventually put the engine management light on too. I believe it left a code at this stage. Yeah, all on warranty.
 
1 - 8 of 8 Posts
Top