Kia Owners Club Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Folks,

I hope someone may have come across this before. I have a 2014 Ceed Estate (1.4cdri) that about 3 weeks ago basically started to make a growling noise when I accelerated. There was a vibration in it and then it was very slow to accelerate. There was no engine management light to indicate the obvious issue.

The local mechanic replaced an injector as his computer indicated this was the issue and when I got it back it was fine. For about 5 mins! - although the shaking/vibrating had gone, you could still hear the growling noise as you went through the gears. When you got to 4th gear, the car essentially started to misfire. The car really struggled. So I've brought it back and to be fair to the mechanic he has done alot of work trying to figure out whats causing this.

So I'm wondering has anyone ever experienced this kind of issue before? If so, would you be so kind as to let me know what you did to resolve it? Its been suggested to me that the four injectors need to be reset/refurbished and the proposed bill will be pricey!

Any advice would be very welcome. Thank you in advance for any suggestions.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Hi, issue looks like its ok now. The replacement injector coding needed to be done a second time with a different computer. Seems to have sorted it anyway. Thanks to everyone who took the time to look at itt
 
1 - 2 of 2 Posts
Top