Kia Owners Club Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi all, I have just purchased a 2013 Ceed 2 1.6 crdi, it was advertised as having cruise control, with speed limiter. I can work out how to use the speed limiter, but cannot for the life of me find how to activate the cruise control, the vehicle came with no owners manual. Help!
 

·
Super Moderator
Joined
·
3,335 Posts
Welcome - I'll move you to where the owners are!
 

·
Registered
Joined
·
152 Posts
Hi all, I have just purchased a 2013 Ceed 2 1.6 crdi, it was advertised as having cruise control, with speed limiter. I can work out how to use the speed limiter, but cannot for the life of me find how to activate the cruise control, the vehicle came with no owners manual. Help!
You have two flip switches. One selects speed limiter if you press up and cruise control of you press down. A second press toggles these things on/off.

The second switch sets/adjusts the speed. For cruise control, once you enable it, you then have to set the speed. Press the second switch down to set your current speed or up to resume to your last set speed.

So basically, from an off status.....
1. Press left switch down to select cruise.
2. Press right switch down to select cruise speed as current speed.
3. Press right switch up or down as required to adjust cruise speed.

Also, I think cruise will not function from a cold start until you have used the brakes at least once.
 

·
Registered
Joined
·
257 Posts
Just to add that usually with cruise control systems - there will be a minimum speed at which it will operate - usually either 30 or 40 mph depending on age and make of car.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
I have tried what was suggested, but to no avail. I can only presume I have a fault with the cruise control itself, I am told the word 'cruise' should come up on the display, but it doesn't. When I engage the limiter, 'limiters does display! Any quick fixes out there, or is it a trip to the Kia Doctor?
 

·
Registered
Joined
·
76 Posts
I have tried what was suggested, but to no avail. I can only presume I have a fault with the cruise control itself, I am told the word 'cruise' should come up on the display, but it doesn't. When I engage the limiter, 'limiters does display! Any quick fixes out there, or is it a trip to the Kia Doctor?
Mine is a symbol not a word. Think if the HUD is the more advanced it might have one. Below is an image from my manual.

7840
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
Thankyou for your reply, that helps me to know I definitely have a fault. Will see if my tech can plug into OBD port first before a call to Kia dealer.
 
1 - 10 of 10 Posts
Top