Kia Owners Club Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone


I just picked up a 58 plate Ceed last week, but the front windscreen washers don't seem to be working properly! They were fine on the test drive but now the water hits the windscreen only around an inch from the bottom of the screen
Water also dribbles back down the bonnet. Can anyone think of a reason for this and maybe even a solution?

Thank you
 

·
Registered
Joined
·
2,252 Posts
Welcome Babybeak, Your skooshers might need adjusting. If I remember right mine were quite low on my Ceeds. Take it back and get them to have a look at it. Thats what the warranty's for.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks Davy, I was hoping it would be something I could sort myself as it's a bit of a pain for me to get to the garage
I'll give the dealer a 'phone tomorrow though and see if I can get it booked in.
 

·
Registered
Joined
·
2,252 Posts
Well you could try and adjust yourself with a stiff needle or pin if you like and if it does not make any difference then take it to dealer as the pump might be weak.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I did have a go with a pin but there was nothing doing unfortunately, maybe it is the pump. Thank goodness for the warranty!
 

·
Registered
Joined
·
328 Posts
I had a similar problem last month on the Rio.

The washer jets were very low then stopping after 10 seconds yet the pump was still working.

I took it to Kia and they said the pump was blocked.
I initially was confirmed that it was covered by warranty, it later turned out this blockage of the screen wash pump was not covered by the warranty.

But it only cost £17 to remove the blockage and everything fine now so I cant complain really.
Not a major problem but I just thought id let you know.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Hi,


Thanks for your reply, I had it in the garage today and it turns out the pipe from the pump had come loose so, although water was getting through, it wasn't powerful enough to get the spray up the windscreen! All sorted now and no charge at all, they only had to re-attach the pipe properly and stick a clip on it to stop it coming off again.
 
1 - 9 of 9 Posts
Top