Kia Owners Club Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Started the Sedona 53 auto tonight to come to work, and for the first half mile the Hand Brake light and Battery light where showing on the dash but only faintly.


They went of after the first half mile, its the first time I have seen them on.



Should I be worried? Could it be just a earthing problem? or something major going to happen.



Thanks Richard.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #3 ·
Thats what I was afraid could happen. I wonder how much a new one will be? Not cheap no doubt.
 

·
Registered
Joined
·
390 Posts
Hi. Found a site company that does only alternators and starter motor repair kits. From posts these are good. The site is www.repairkitsuk.com.
Have a look at the write up by the owner looks good. For new items not expensive either.There is a mobile number to ring for free advice too, I will be using the statrter motor repair kit and the pics off the site for mine.
Poss help there.
Steve Gx Blackpool
 

·
Registered
Joined
·
20 Posts
I had exactly the same issue on 30th. I have just picked up an 06 (old shape) 2.9 auto and was driving it home when these 2 lights startedflickeringdimly.

It was raining hard and I wondered if it could have been water ingress?

The lights are off now and all is OK.

Keep you posted.

Mike
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #7 ·
Mine came on the once for 1/2 mile, and touch wood they have not come back on again since.


Im hoping it was just a glitch Mike. Hopefullyyours is the same, and nothing more.
 

·
Registered
Joined
·
20 Posts
Hope so.

I have read back through the forum and a few people have had the same problem. It has generally been thealternator. Although, some of the past threads never concluded so the problem might have just gone away.

I think I will WD40 the connectors on mine and see if it helps.Apparentlythere is a little black plug on it which I think might have got wet in the heavy rain on Friday. But Ihaven'thad a look yet so have no idea what is under the bonnet.

Fingers crossed.
 

·
Registered
Joined
·
20 Posts
Hi Cavey

The problem just went away and it seems OK now. I think it was just water ingress from the heavy rain on the day.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #11 ·
The light as never come on since that first time, so touch wood its ok.



But now Im having trouble with the starter motor, ( I think its that) Some times I go to start her and nothing happens, I try a few times and eventually she starts. Going to take it to be looked at this week hopefully.
 

·
Registered
Joined
·
399 Posts
There have been a few posts on here with similar problems from cleaning the contacts to changing the starter motor or solenoid. Best bet is to disconnect the earth battery cable then cleaning the electrical terminals on the solenoid and starter motor before investing in a new starter.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #13 ·
Yea Ill try that thanks. Hopefully its just the contacts that need cleaning, It starts after a bit, thats why I dont think the starter motor is knackered. If it was starter motor then it wouldnt start at all.
 

·
Registered
Joined
·
399 Posts
Sometimes if it's just clicking it could be the solenoid, and the only cure is a new solenoid, much cheaper than a complete starter, good luck!
 

·
Registered
Joined
·
399 Posts
MININUT said:
Sometimes if it's just clicking it could be the solenoid, and the only cure is a new solenoid, much cheaper than a complete starter, good luck!

Also have a look at Stevegx's "how to remove starter with quality pics"!, thought that you might have seen his thread?
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #16 ·
Starter kit ordered from Carl. Excellent service, open 9 till 9.


Whilst car was at mechanics though he reccomended me to get some new front dics and pads, anbody any idea who do them at the best price?
 
1 - 20 of 25 Posts
Top