Kia Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
2007 Sportage XS 2.0 Petrol
Joined
·
4 Posts
Discussion Starter #1
Hi fellow Sporties,

I purchased a 2007 petrol 2.0 recently for the wife as a second car and so far so good. Seems to drive OK other than screeching sound on full steering lock (I suspect alternator belt not taught enough) but taking it in to local indy to take a look. The other issue which is what I would like some help on is the digital climate control system. To engage AUTO on the climate control unit, you simply push the left dial button in and the word AUTO should display on the digital screen. Unfortunately, it does not display anything however many times I push the button. I have taken the front fascia out and disconnected the climate control unit by taking off the two plugs connected to it. On reconnection, the word AUTO displays on the screen until I change the temperature or change the heater fan speed. All the manual controls including the Air Con (blowing nice and cold) and the front and rear windscreen buttons are all fine.

I purchased a cheap second hand unit from a breakers yard and connected that today. It is doing exactly the same thing as the original unit in that everything is working except the AUTO button so I can therefore discount there being a problem with the digital unit. Is there perhaps a relay or a fuse that may be causing this or can there even be a special way (using a combination of buttons) to disable the AUTO button?

Any help would be appreciated as I like (so does the wife) the use of the AUTO button where you set the temp and let the car do the work for you. As I said earlier, the Air Con is blowing cold and the heater is blowing hot in manual mode as expected.

Thanks in advance

Pashar
 

·
Registered
Joined
·
5,212 Posts
Changing set temp should nt turn off auto.

Changing fan speed will disable auto (think about it - you are telling the system you want to control the fan speed) so that is normal

I wonder if it is something like the cabin air temperature sensor?
 

·
Super Moderator
Joined
·
4,217 Posts
Auto button usually has a small line in the middle that lights up when it is in Auto mode.
 

·
Registered
2007 Sportage XS 2.0 Petrol
Joined
·
4 Posts
Discussion Starter #4
Changing set temp should nt turn off auto.

Changing fan speed will disable auto (think about it - you are telling the system you want to control the fan speed) so that is normal

I wonder if it is something like the cabin air temperature sensor?
Hi Turnup,

Thanks for the response. Is the cabin air temp sensor the one on the dashboard near the windscreen? If so is there anything I can check to see it is functioning correctly?

Thanks again
 

·
Registered
2007 Sportage XS 2.0 Petrol
Joined
·
4 Posts
Discussion Starter #5
Auto button usually has a small line in the middle that lights up when it is in Auto mode.
Hi iooi,

I cannot see any light/LED in the centre of the dial. Also, the AUTO is not showing on the display.

Thanks
 

·
Registered
Joined
·
121 Posts
Hi Turnup,

Thanks for the response. Is the cabin air temp sensor the one on the dashboard near the windscreen? If so is there anything I can check to see it is functioning correctly?

Thanks again
That's the sunlight sensor. The temperature/air quality sensor is to the left of the steering wheel behind a small grid of 4 horizontal gaps. It is hard to get out as you need to contort yourself to get to the 2 screws behind the dashboard, but it is possible and a second hand replacement is about £30 or new is about £120.
 

·
Registered
2007 Sportage XS 2.0 Petrol
Joined
·
4 Posts
Discussion Starter #7
That's the sunlight sensor. The temperature/air quality sensor is to the left of the steering wheel behind a small grid of 4 horizontal gaps. It is hard to get out as you need to contort yourself to get to the 2 screws behind the dashboard, but it is possible and a second hand replacement is about £30 or new is about £120.
Thanks Turnup.

Found it. Will see if I can get to it tomorrow and test out the resistance using a multimeter to see if it is functioal.
 
1 - 7 of 7 Posts
Top