Kia Owners Club Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My IPhone 13 pro max will connect when plugged into my 2020 optima, but it will randomly disconnect from CarPlay (alert will pop up on dash stating it’s reconnecting to CarPlay). The odd thing is that the music will still play through the phone (not through car speakers) when it disconnects and the car will still move the song counter as if it is still connected.
This just started within the past 3 weeks. Tried forgetting my car and reconnecting which didn’t work. Tried restarting phone which doesn’t help. Tried multiple different cables which doesn’t help.
I see a lot of other people having problems but not a clear solution. Anyone find anything that has worked? Since this just started, I assume it has something to do with a software update for Apple but I could be wrong. I messaged Apple and they pointed me here…
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Has it worked previously with no problems?

Interesting Apple sent you here. 🤪
Yes. It worked perfectly fine before these current issues and just started acting up about 2 weeks ago.
I will say, I am diabetic and my sensor connects to my iPhone through Bluetooth. When my glucose drops/rises my phone will beep but not through the apple play in my car. It will almost disconnect from the apple play to alert and then go back to playing through apple play.
now, this does not happen if I am using headphones with a lighting/aux connector. The beep will just come through the headset. So I’m assuming it has something to do with apple play? This has happened ALL the time, since I’ve had the car.I mention this because this is kind of what is happening now except there is no alert coming through from anything, it just randomly disconnects.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
So, I may have found a sido fix. I have to connect my phone through Bluetooth then connect it via the usb - lightning cable to use apple play. Then it does not disconnect. Or, if it is, it continues to play the song/sound through Bluetooth. Was driving for about 2 hours today with no reconnects. So there’s that lol
 
1 - 5 of 5 Posts
Top