Kia Owners Club Forum banner
1 - 17 of 17 Posts

Registered
Joined
7 Posts
Discussion Starter · #1 ·
Hi, I picked up a new Rio 2 on Saturday. I'm having an issue with the wireless Apple Carplay. Every few minutes the Carplay display cuts to a black screen and I get a message saying "Phone is not responding. Please reconnect it and try again". The music, maps, etc. does not actually cut out but you have to go back into Carplay to get the maps, music app, etc. back up on screen. I had no issues with my wired Apple Carplay connection in my previous Rio.

A Google search reveals this seems to be an issue with the Kia infotainment head unit and wireless Carplay after an iPhone update. I'm going to mention it to the dealer when they phone with their aftersales call but I wanted to check if anyone has had this issue? My Google search has only returned this issue from customers in the US and Australia where an update to the head unit software is in the process of being implemented. I can't seem to find any UK examples of this online, so I suspect the dealer will have no idea what I'm talking about.
 

Registered
Stonic 1st Edition
Joined
1,675 Posts
I don't think it can be cable connections as it is the wireless version of Carplay
WiFi hotspot or BT going to sleep on the phone? Is battery saver on phone enabled?
 

Registered
Joined
7 Posts
Discussion Starter · #6 ·
What age car?
Wireless is not enabled in the UK as yet.
Brand new. If it isn鈥檛 enabled in the UK my car must be an anomaly. I assumed it was a wired connection as I didn鈥檛 realise wireless CarPlay was even a thing. However, it connects whenever I get in the car with the phone in my pocket
 

Registered
Joined
3 Posts
Brand new. If it isn鈥檛 enabled in the UK my car must be an anomaly. I assumed it was a wired connection as I didn鈥檛 realise wireless CarPlay was even a thing. However, it connects whenever I get in the car with the phone in my pocket
Did you do any specific setup to get it working? I've tried digging around all the menus on my 21 GT-S and can't find anything, i'll check the firmware in the morning. I've noticed you're the second person on this forum who has wireless carplay but also trim 2, so perhaps it's only working on that model currently, strange.
 

Registered
Joined
3 Posts
If it helps, this is the current version running on my car, no wireless option but wired carplay works fine.

Definitely appears to be an updated version, so perhaps they removed it as it was causing issues?

9822
 

Registered
Joined
1 Posts
11568

I鈥檓 having the same problem with my Kia Rio where my iPhone will disconnect every couple of minutes.
Is there newer software available than this? I鈥檓 hoping that getting it updated might solve the problem.
 

Super Moderator
Joined
10,582 Posts
View attachment 11568
I鈥檓 having the same problem with my Kia Rio where my iPhone will disconnect every couple of minutes.
Is there newer software available than this? I鈥檓 hoping that getting it updated might solve the problem.
Well you have the old type 1 software (black/white) Type 2 (Purple) as per #5 might help. As there was a known issue with a IOS update causing problems.

If you ask the dealer about software updates and they say there are none. Then say can you update maps, as the last map update 2021 type 2 was part of the update.
 

Registered
Joined
3 Posts
I am from Canada but what I found that really helps is that the Kia is connected to wifi at low data and when I changed the settings the not responding all but stopped.
To do this go to your IPhone settings
Wifi settings
Find your cars Id
Hit the information button
Turn off low data

you have to be in connection limit of your vehicle and the vehicle turned on.
 
1 - 17 of 17 Posts
Top