Kia Owners Club Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
234 Posts
If you lift the hood with engine running and air con on you will see if the pulley is just being driven by the belt but not turning the pump. As for gas do as previous post, and get checked with an air con specialist who if leaked,will find the leaking cause.
Hi on my ceed when I turn on the aircon it doesn't cool and makes what sounds like a high pitched metallic grinding noise. I can see the compressor or pump at the front at the bottom when I open the bonnet but here's the strange thing. When I switch on the ac the belt is running and everything is turning nicely. When I switch the ac off (including even the normal fan) it still keeps running from what i can see.

Should that be the case? Or will it look like it's running but have disengaged from the pulley being turned?
 

·
Registered
Joined
·
234 Posts
The pulley will always be turning with engine running but clutch only engage to drive pump when air con switched on.
Been doing a bit more investigating it mine. So the clutch appears to be permanently engaged? Spins if the fan is on or off with or without ac selected. I've tried - obviously with the engine off - to see if I can freely rotate it by hand and it's a stretch from above without the headache of removing the plastic undergrads but it certainly doesn't appear to be anything other than engaged. I have checked the relay fuses at the dash and under the bonnet and both are ok. I'd be tempted just trying to diy refill mine but don't want to throw the guts of £100 on r1234yf when I have suspicions that's only one part of it.
 
1 - 2 of 2 Posts
Top