Kia Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Looks like my 09 1.6crdi has developed a wee leak from the Air con system, on the lower right side of the matrix behind the front bumper. I have actually cleaned off what would appear to be system fluid/lubricant from around what appears to be a riveted bracket, visible between the lower two grille slots.
http://twitpic.com/4o3gf4

Anyone else experienced anything like this?
 

·
Registered
Joined
·
207 Posts
If your car is that new surely you can get it fixed under warranty?

Sounds like an assembly fault.

Cheers.
 

·
Registered
Joined
·
1,165 Posts
Dervheid


As Quilman says its a one word answer, WARRANTY. Take it to the dealer to fix.



But first are you sure its a leak? All A/C systems defrost when you stop (like a fridge) and the water runs out, out Ceed leaks in the front drivers side corner.



Paul
Edited by: suttonseven
 

·
Registered
Joined
·
226 Posts
Often the refrigerant has dye in it, so you can see when it leaks out. I dont know if Kia do that. But if you do get it recharged, request that dye is added so that any future leaks are easy to spot.

FYI, My air con will get to 9 deg C with the blower on full and the thermometer up close to the vent, reading taken after 3 mins. As guide, yours should too.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
suttonseven
Yup, definitely the air con, as I observed what can only be described as 'bubbling' in the centre of the little rivet in question (see pic). Plus the exchanger is again slightly wet around that point, after my cleaning it up on Friday, and it ain't water. Leak first spotted on passenger side front, dripping from exchanger lower mount. All been cleaned up for monitoring purposes. No sign of there being any tracer dye though.

Uncle Zen
Not checked my air con's effectiveness yet, although it is still blowing colder on than off.
As for your 9C reading, you didn't give an ambient temperature for reference. (or if I was being REALLY pedantic, the relative humidity, as this will also have a bearing on the end result, but I'm not so...)
Will be getting in touch with Kia dealer. Not the dealer I bought from (not Kia) but another arm of a large, well known scottish motor dealers (no names, no pack drill...)
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #7 ·
Latest update.
Car into dealers. Despite having 2 weeks lead-in and having been told where the leak clearly was (which they confirmed), I have to take it back this week as they didn't have the part in stock (condenser). Not used to this low level of service. Skoda dealer always listened to the info they were given, and either had parts in, or next day at latest. Not best pleased but as long as it gets fixed...
That said, now having some blue smoke on cold start, and a wee bit reluctance to fire up (glowplugs perhaps? must check other threads)
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #8 ·
New condenser now installed. Keeping an eye on start ups after the failure of the earth to the engine, which could have been affecting the effectiveness of the glow plugs, but a happier bunny again.
 
1 - 8 of 8 Posts
Top