Kia Owners Club Forum banner
21 - 32 of 32 Posts

·
Registered
Joined
·
815 Posts
Is that UVO software as well? If so maybe it’s different to the software without UVO as it seems to be that which is playing up.

I can’t even get the GPS time to show correctly now. It’s always at least exactly 1 hour in front and daylight savings puts it 2 hours in front.
Map itself looks fine but the speed sign recognition is really bad.
even though my car is equipped with camera to read signs, it will read the sign but after a few yards etc it will revert back to (- - -) until next sign again. National speed limit signs are not recognised at all anymore either.

car doesn’t seem to tell me now if there are delays on my route etc so something is off with the update but maybe only certain variants.

hopefully they will release a new update to correct this one.
Yes, it has UVO/Connect


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
719 Posts
Yesterday evening I had no traffic data, but back this morning, so I guess they had a connected services problem yesterday...
That may be why I wasn’t getting anything on mine then. I tried a couple of routes today and does seem to show traffic now so hopefully that’s sorted.
unfortunately sign issue and clock issue still persists.
 

·
Registered
Joined
·
53 Posts
Nope, I don’t think it’s anything to do with resetting the system. I did a reset to default and same thing happens.
it would seem that there is no data available for the speed limits meaning it just throws back the three - - -symbols.
When you pass a sign it will then update as it should but seems temporary and after a short amount of time the 3 - - - pops back again.
also, national speed limit signs are no longer recognised. I was in a 50 zone which showed fine after it passed the sign, went into the dual carriageway and passed the sign and (- - -) appears again where it used to and still should have shown as 70mph. So no idea what’s up but fact it’s a few of us on here with same issue would indicate that there’s a problem with the update and data for signs is missing currently.
I have a MY18 sportage and after updating I have exactly the same issue with the 3 ---. So it seems to be a problem with the update. Not sure if the onboard camera is picking up the signs at all. The speed indication works for a few seconds but I think this is from the GPS. I went through some Motorway works zones and the speed display indicated a 50 mph zone but the physical signs said 60.
 

·
Registered
Joined
·
719 Posts
I have a MY18 sportage and after updating I have exactly the same issue with the 3 ---. So it seems to be a problem with the update. Not sure if the onboard camera is picking up the signs at all. The speed indication works for a few seconds but I think this is from the GPS. I went through some Motorway works zones and the speed display indicated a 50 mph zone but the physical signs said 60.
Yes, same issue and it’s most definitely to do with the camera recognition. I’ve actually turned the camera sign recognition off for now until the software is fixed.
when you turn it off, the speed sign indicator will disappear from dash. However, in the sat nav screen, the speed limits will now show and no more (- - -).
Once fix is in place, I will turn the camera recognition back on.
 

·
Registered
Joined
·
1,831 Posts
I was about to update my Gen2 infotainment this afetrnoon. Glad I didn't now.
I quite often rely on the speed limit feature, especially whn in an unknown area.
 

·
Registered
Joined
·
815 Posts
I was about to update my Gen2 infotainment this afetrnoon. Glad I didn't now.
I quite often rely on the speed limit feature, especially whn in an unknown area.
MOST of the problems are associated with the National Speed Limit zones, and getting —- instead of a 30 sign when setting off. In my case at least the majority of it works as expected, but it does get confused occasionally


Kia Xceed 4, 1.5 DCT MY20
 

·
Registered
Joined
·
1,831 Posts
I've always found until it reads the first road sign it doesn't know the speed limit.
For instance, I can leave my estate and join a local 30mph street and it won't pick up any speed limit until I pass through in to the 40 zone a mile up the road.
Unless the map is on, at which point it pulls the data from the map instantly.

Is this still the case, or are there other issues with it ?

At the moemnt, mine has never been confused as far as I'm aware.
 

·
Registered
2017 GT Line S 1.6 Petrol AWD
Joined
·
98 Posts
Upgraded the infotainment system today version as image.
View attachment 12599

Had a quick look around the upgrade & not much has changed. :(

The only problem I've seen is the road speed limit info icon in the nav screen & instrument binnacle is not displaying a speed just three - - - :unsure:

Anybody know how to fix this issue?
I've just updated my 17 Sportage to the same version.

As per other owners there is a problem with the speed limit display.
The camera seems to pick up the speed limits most of the time (even temporary limits) but the actual display disappears from both the navigation screen and the dashboard screen after a random time. Which then displays ---
I discovered that disabling the speed limit through the settings from the steering wheel stops the camera operating, this enables the navigation screen to display the speed limits (although these are the ones setup in the sat nav so are sometimes wrong and will not change for temporary changes).
Question is, when will we know when Kia have sorted the issues and hopefully have a new download ready?
 

·
Registered
2019 Ceed first edition
Joined
·
208 Posts
Question is, when will we know when Kia have sorted the issues and hopefully have a new download ready?
I'm sure it'll be plastered all over these pages but I think first of all we need them to acknowledge the problem.
Keep an eye on the version and date on the update program and you'll know if it's changed as the last bit is the date in reverse. Ie. 211130 would be today's date
 

·
Super Moderator
Joined
·
6,829 Posts

·
Registered
Joined
·
337 Posts
Discussion Starter · #31 ·
I've just updated my 17 Sportage to the same version.

As per other owners there is a problem with the speed limit display.
The camera seems to pick up the speed limits most of the time (even temporary limits) but the actual display disappears from both the navigation screen and the dashboard screen after a random time. Which then displays ---
I discovered that disabling the speed limit through the settings from the steering wheel stops the camera operating, this enables the navigation screen to display the speed limits (although these are the ones setup in the sat nav so are sometimes wrong and will not change for temporary changes).
Question is, when will we know when Kia have sorted the issues and hopefully have a new download ready?
I'm waiting until everything settles :) Hopefully Kia will sort these known issues eventually :unsure:

Other than the speed limit issue everything else seems to be working. My Sportage was running on 2018 navigation maps, the new (to me) detailed turn info is a big improvement:)
 

·
Registered
2019 Ceed first edition
Joined
·
208 Posts
I liked the 2018 maps. The roads had different colours signifying main, side roads etc. The newer maps, everything is the same.
 
21 - 32 of 32 Posts
Top