Kia Owners Club Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
828 Posts
You will have to drive passed a sign & it will pick it up. Mine has done that today. After update as it seems to forget the speed limit prior to update.
That’s a good point. The Speed Limit Display on my car was always - - until I had driven past the first sign, and then it read it. Not before.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
828 Posts
@vengablue ; I can’t think of anything to resolve except maybe a reset of the head unit. The update left me with a few defaults that I needed to change, like camera alerts being off, but nothing actually being wrong like that.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
828 Posts
Is that UVO software as well? If so maybe it’s different to the software without UVO as it seems to be that which is playing up.

I can’t even get the GPS time to show correctly now. It’s always at least exactly 1 hour in front and daylight savings puts it 2 hours in front.
Map itself looks fine but the speed sign recognition is really bad.
even though my car is equipped with camera to read signs, it will read the sign but after a few yards etc it will revert back to (- - -) until next sign again. National speed limit signs are not recognised at all anymore either.

car doesn’t seem to tell me now if there are delays on my route etc so something is off with the update but maybe only certain variants.

hopefully they will release a new update to correct this one.
Yes, it has UVO/Connect


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
828 Posts
I was about to update my Gen2 infotainment this afetrnoon. Glad I didn't now.
I quite often rely on the speed limit feature, especially whn in an unknown area.
MOST of the problems are associated with the National Speed Limit zones, and getting —- instead of a 30 sign when setting off. In my case at least the majority of it works as expected, but it does get confused occasionally


Kia Xceed 4, 1.5 DCT MY20
 
1 - 5 of 5 Posts
Top