Kia Owners Club Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

I have a 2012 Picanto where the speedo is acting up.

My sister helped me clean the car and i think she might have used something wet on the dashboard and my suspicion is that some water has gotten under the dashboard.

See video of the speedo here:
https://www.dropbox.com/s/7x6cxreqr36kgcf/VID_20190607_122344.mp4?dl=0

Has anyone seen this before? Is it easy to replace by yourself?

BR/Joakim
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Just posting an update to see if anyone have any more suggestions on how to solve the issue.

Right now the speedometer is completly dead - its not responding anymore like in my video.



I have tried the following so far:

* Bought an ODB scanner and checked for error codes - no error codes found.

* Checked live data in ODB scanner and it views the vehicle speed correctly when driving. - This made me think that there were something wrong with the speedometer itself.

* Bought an extra instrument cluster on a junkyard and installed it, it has the same issue as the old one. Every gauge is working except the speedometer.

* Checked all the fuses

* Also tried replacing the passenger compartment fusebox after a tip from a kia workshop - still the same issue.


Starting to think this could be a wiring issue, or perhaps an issue with the ECU/ECM. Still no error codes on the ODB scanner though.



Anyone got any tips?
 
1 - 2 of 2 Posts
Top