Kia Owners Club Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all. Just experienced a problem starting the car. It is a 2012 CRDI that I have owned for about 4 years and has done about 45k miles. When I pressed the brake pedal and the start button I just got the warning lights with no attempt to start from the engine. There is nothing wrong with the key fob battery or the fob itself - I tried inserting it in to the holder in the armrest. None of the warning lights were flashing and there were no chimes - there was just no attempt from the engine to start, it was as if the engine had been removed. I also tried to move the selector from 'P' in case the re was an immobiliser switch problem, but of course there was no movement. One strange thing was that the brake pedal went 'rock hard' and I could hardly press it, although it just depressed enough for the lights to come on. After numerous attempts over about 10 mins the engine started and the brake pedal went to its normal position. This is the second time this has happened in the last 6 months and last time I had the engines battery checked in case it was too low to turn the starter - it came back as no problems. The car itself is not giving any clues what the problem might be and I have checked everything the handbook suggested. The car is working now as if there hadn't been a problem. I did see an error message a few weeks ago saying something about the steering lock was not positioned correctly.
 

·
Registered
Joined
·
5,137 Posts
Plug OBD reader in and see if any fault codes stored.
 
1 - 2 of 2 Posts
Top