Kia Owners Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've just bought an 09 Sportage XE. Only done 1400 miles yet but I like the car. When I picked it up it had a very slight misfire as you worked through the gears, but only in 2nd at 1500 revs wth gentle acceleration. I hoped that would wear off with some use. The problem got worse and has spread to all gears as you smoothly accelerate away or dawdle along in Traffic. I took it back to the Dealer under Warranty and although they have "experienced the problem" and admit there is one, the diagnostic computer comes up with no fault code. At the moment I have been sent back on to the road to see how the fault developes as, they can;tfix what the computer can't find! I have registered a complaint with Kia UK who, at this time, support their Dealer. Any advice please?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the advice - I will pursue that further. Sorry for the delay, I have been away. Its certainly getting no better!
 

·
Registered
Joined
·
5 Posts
do pursue the dealer the misfire or hesitation you are feeling is 9 times out of 10 due to the egr system fitted to the euro 4 spec 2.0 diesel engine in your car not the valve itself but the electronic control of it . there is a fix which has improved 99% of the cars i've seen , cleaning out the carbon build up from the egr cooler valve and inlet manifold carrying out the ecm update {being an 09 yours should be on the latest software version anyway} and the the forced regeneration of the carbon particulate filter {cpf} should sort it but they must check the 4wd system unless yours is the 2wd variant as the other 1% have had 4wd faults giving verysimalar symptoms !

hope this helps stu
 
1 - 4 of 4 Posts
Top