Kia Owners Club Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2003 2.0 petrol sportage and it has started to run hot and I an at a loss why.It had a MOT at the beginning of the month and they had problems getting it pass the emmission test and had to rev it very high to clear the system.
Now its overheating after about 10 miles and blowing water out of the expansion bottle,I brought a new rad cap which keeps the water leak down but the temperature is still higher than I would like it to be.
Has anybody got any ideas what I need to check next???
 

·
Registered
Joined
·
4 Posts
Check for oil in the coolant or coolant in the oil.
A lot of mayo under the oil cap or even on the dipstick, though this can also be caused by lots of short journeys.Stuck thermostat or a blocked radiator perhaps.
More than likely the head gasket has given up, compression test should give you a fairly comprehensive answer.

How does it drive?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I have worked through the cooling system,and replaced the thermostat and radiator,There was not a thermostat in the housing when I opened it up so I am wondering if this engine had a problem before I brought the car.There is NO trace of water in the oil and the pots give the same reading within 2 Psi on my test gauge,even when you drive it it runs sweetly and takes about 5 miles before the system temperature starts to raise so I am thinking like you that the head gasket is allowing a slow let by into the water jacket so my next project is to strip the head and get it checked for flatness and rebuild with new gaskets.
 

·
Registered
Joined
·
4 Posts
Ah, excellent, someone that doesn't think I'm speaking Spanish when talking tech.I have read about a few of these cars cracking the heads too, much like Hilux's do. So I'd check that out as well, though you said about checking for flatness, so you obviously know what you're doing.

Good luck.
 
1 - 4 of 4 Posts
Top