Kia Owners Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Just had my 2005 2.9 diesel in for 60k service. New timing belt kit, new belts etc. before service it was running as sweet as a nut. Fetched it back yesterday & drove it for a couple of miles before visiting family. Started itagain & it seemed to take a lot longer for the engine to start but it started. Problem was engine check light came on but it drove home ok. Stopped engine and left for a minute & it started ok but seemed to turn over longer than it used to. Engine light didnt come on this time. Got up this morning & it would turn over but wouldnt start. Called at garage who came to look at the car & they couldnt get it to start either. Anyway they got it going & said there was an airlock in the fuel line/filter ( not sure which) Been out in it tonight. Drove a couple of miles again & it was fine. Stopped car & went out again about 45 mins later & when starting it was turning over a long time again but it started. Drove about a mile & it seemed to loose a bit of power & the engine light came on again. Seemed ok for a bit & then got sluggish again. Got home ok, turned engine off. started it again & it seemed ok. Thats twice now i've only driven it for 3-4 miles & this has happened. Bet it doesnt start again in the morning like today. Anybody any advice except go back to the garage again. Just cost me £800 for the service & MOT.
 

·
Registered
Joined
·
6 Posts
Morning Spire just a thought you could try, by the side of the filter there is a black rubber thing. By pumping this thing it primes the filter. before starting the car try pumping it until it goes firm last time i changed the fuel filter i had to do it on mine to expel the air in the pipes. it does sound like a fuel prob...was it a kia dealer that serviced it?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
I will try that in the morning. Just one question. Do you have to take any pipes off the filter first ? Is so which one of the 3 ? Thanks for the advice. No it wasn't a kia dealer that serviced it. Couldn't afford to pay their prices.
 

·
Registered
Joined
·
887 Posts
Crikey £800 for a 60k service not at a dealer... ?!
Is it a genuine filter, had a lot of issues with the non genuine types, slightly different design, and seem to cause some problems.
Shouldn't be an air lock after you've run it, they expell thier air very quickly.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Thanks for advice kilravock. Tried priming filter & it worked. Trouble was when i went out in sedona again it conked again & wouldnt start. Primed again, went to fill up with diesel & its been ok since. Think it must have been due to low fuel even though the petrol light hadnt been on.
 
1 - 5 of 5 Posts
Top