Kia Owners Club Forum banner
uvo
1-6 of 6 Results
  1. Main Message Centre
    Hi there is anyone else getting blank white screen when logging into the updated UVO app? I am on iphone 11 software version 14.8 I have turned my phone off and on. Deleted the app and reinstalled it. Each time I try to log in to control the charge start time of my XCeed Phev all I am met with...
  2. Kia Customer Support
    When are you going to fix the current issue with UVO Connect? Since the beginning of September it keeps saying 'no signal in your area' I cant use any features on the UVO app and I'm fed up with being fobbed off by the dealer saying they are in the same situation, as they cannot connect new...
  3. Main Message Centre
    Hi all, Is there any reason that the HVAC controls on the UVO app could not work for the Sorento Hybrid? It seems this option is only available on the pure EV models which is disappointing.
  4. Niro
    Hi everyone. Still playing around with my new e-Niro. Trying to see how to use the app to pre-heat the car remotely. Anyone worked that out? Thanks!
  5. Niro
    Forgive me if I’m being dim. Just taken delivery of a 2021 MY e-Niro 4+ and I’m really pleased with it. I’m trying to connect Kia Live and the instructions tell me I need to set up a WiFi hotspot from my phone and connect the car to this. So far, so good, that’s what I’d done on my Mazda...
  6. Sportage 2016-2021
    Hi all! Enjoying my new Sportage "3", activated Uvo Live, linked with the phone app etc etc ... all good, but from the phone Uvo app, in the map, I select a destination and hit "send to car" it says it successful but it nowhere to be found in the car infotainment system. I went through every...
1-6 of 6 Results
Top