New Posts New Posts RSS Feed - Slow throttle response from idle
  FAQ FAQ  Forum Search   Register Register  Login Login


Welcome to the Kia Owners Club Forums!

If you're new here, please introduce yourself in the Newbies Kia Forum, we have forums for each Kia Model so please make sure you post in the correct forum.

Slow throttle response from idle

 Post Reply Post Reply Page  123 4>
Poll Question: Kia Sedona - slow response from idle
Poll Choice Votes Poll Statistics
0 [0.00%]
5 [100.00%]
You can not vote in this poll

Author
Rich F View Drop Down
Newbie
Newbie
Avatar

Joined: 01 Sep 2013
Location: Bristol
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Rich F Quote  Post ReplyReply Direct Link To This Post Topic: Slow throttle response from idle
    Posted: 01 Sep 2013 at 9:53am
Hi All, I'm looking to purchase a 2006 KIA Sedona 2.9 CRDi. I have noticed, when pressing the accelerator that there is a delay from idle until the revs pick up. Once on the move the car drives fine. Is this delay normal? Or could it indicate a potential problem? Thanks Rich.
Back to Top
Sponsored Links


Back to Top
Ade View Drop Down
Newbie
Newbie
Avatar

Joined: 03 Mar 2009
Location: Yorkshire
Status: Offline
Points: 17
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ade Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jul 2014 at 10:00pm
My 2006 model did this just the same when I bought it and it was 1 year old. Took it to Kia dealers in Leeds and they downloaded a fix for the fuel management system. Took 30 mins and its been fine since. Had the car 6 years now.
Back to Top
Bluey View Drop Down
Groupie
Groupie


Joined: 13 Jul 2010
Location: Lancs
Status: Offline
Points: 64
Post Options Post Options   Thanks (0) Thanks(0)   Quote Bluey Quote  Post ReplyReply Direct Link To This Post Posted: 25 Aug 2014 at 8:10pm
Mines a 2008 (January reg) 2.9 Crdi and is slower to pick-up revs in neutral than you would expect. I'd seen somewhere on here about a software fix but never had it done. There is sometimes a delay in pick-up when driving that used to worry me, but I've got used to it now! Had the car for three years and not thinking of changing it anytime soon so maybe I should risk going near the Kia dealer!!!
Back to Top
barney50 View Drop Down
Groupie
Groupie
Avatar

Joined: 14 Jun 2014
Location: London
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote barney50 Quote  Post ReplyReply Direct Link To This Post Posted: 22 Aug 2016 at 5:08pm

My 09 plate does the same , thinking of getting the ECU remapped to see if that improves it 
Back to Top
sln8458 View Drop Down
Groupie
Groupie
Avatar

Joined: 20 Jul 2011
Location: Norwich
Status: Offline
Points: 62
Post Options Post Options   Thanks (0) Thanks(0)   Quote sln8458 Quote  Post ReplyReply Direct Link To This Post Posted: 07 Sep 2016 at 8:04pm
We have an 07 2.9,

Ours has done this since local main dealer 'fixed' an engine management light issue, apparently 'it's fine' i was told, but they don't drive it daily.
Ho hum, had it 4 years now, been like this since week 8!

SteveN
Sedona 2007 LS 2.9 Diesel Auto in BLACK
Back to Top
barney50 View Drop Down
Groupie
Groupie
Avatar

Joined: 14 Jun 2014
Location: London
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote barney50 Quote  Post ReplyReply Direct Link To This Post Posted: 07 Sep 2016 at 8:57pm


Thanks for reply , Good to know it sounds normal then , just frustrating when you pull out from a junction and willing it to get going !!

Have it booked in with Celtic tuning for the ECU remap let's hope remapping the ECU might help .

I also tried one of those Pedalbox units but made absolute no difference to rpm speed no matter what setting it was on !!

Edited by barney50 - 07 Sep 2016 at 8:57pm
Back to Top
barney50 View Drop Down
Groupie
Groupie
Avatar

Joined: 14 Jun 2014
Location: London
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote barney50 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Oct 2016 at 9:54pm
Well i had the remap done a couple of days ago with Celtic tuning , and it drives like a different car now , pulls away without delay  , and sounds totally different , kick down is much quicker and smoother too , can hear a faint whine/whistle from the turbo now at lower rpm  (which was not evident before) .

well worth it IMO Smile
Back to Top
Snaggletooth View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Jan 2017
Location: Gravesend
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote Snaggletooth Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jan 2017 at 10:37pm
Just joined forum.  Just bought a 2007.  Has a similar problem of hesitation when pulling away plus a lack of rev build up when in neutral as described by Bluey and barney50.  Had it tested, all is fine according to garage.  Now booked it in to get the ECU remapped.  Happening on Wednesday 11 Jan (subject to weather).  Will post result. 
Back to Top
barney50 View Drop Down
Groupie
Groupie
Avatar

Joined: 14 Jun 2014
Location: London
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote barney50 Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jan 2017 at 11:54pm
Originally posted by Snaggletooth Snaggletooth wrote:

Just joined forum.  Just bought a 2007.  Has a similar problem of hesitation when pulling away plus a lack of rev build up when in neutral as described by Bluey and barney50.  Had it tested, all is fine according to garage.  Now booked it in to get the ECU remapped.  Happening on Wednesday 11 Jan (subject to weather).  Will post result. 


Very pleased with mine , still won't "rev" when in P or N like normal cars do , but once in D pulls away and just keeps going , even get wheel spin now when acceleration is needed pulling out of junctions .

Presuming yours won't "rev" when at a stand still like mine (and other cars) notice it in cold weather when you usually just sit a rev to warm up quicker , obviously can't do that in these !!
Back to Top
Snaggletooth View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Jan 2017
Location: Gravesend
Status: Offline
Points: 10
Post Options Post Options   Thanks (0) Thanks(0)   Quote Snaggletooth Quote  Post ReplyReply Direct Link To This Post Posted: 11 Jan 2017 at 2:04pm
Oh well here's my feedback as promised - he wasn't able to remap the ECU my 07 2.9 Sedona TS - didn't have the software for the ECU.  He did however give it a test drive and put his diagnostics on it before trying the remap.  No problems highlighted.  He did say however that the problem I was experiencing with this sort of lull/miss fire on pulling away was unlikely to be cured by an ECU remap - he said it was more likely to be an injector playing up. Genuine bloke, didn't charge despite spending 2 hours trying to do it, emailing making calls etc. 
Not sure what to do now? Try another remapping company?  Take it to Kia? High quality injector cleaner?  Replace fuel filter? Get the injectors tested? Do the tank filter?
Anyone out there got any ideas??????
Back to Top
 Post Reply Post Reply Page  123 4>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.