New Posts New Posts RSS Feed - excessive smoke and erratic idling on startup
  FAQ FAQ  Forum Search   Register Register  Login Login


Welcome to the Kia Owners Club Forums!

If you're new here, please introduce yourself in the Newbies Kia Forum, we have forums for each Kia Model so please make sure you post in the correct forum.

excessive smoke and erratic idling on startup

 Post Reply Post Reply Page  <12
Author
gtd2000 View Drop Down
Senior Member
Senior Member


Joined: 27 Oct 2011
Location: Galashiels
Status: Offline
Points: 908
Post Options Post Options   Thanks (0) Thanks(0)   Quote gtd2000 Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jul 2018 at 2:00pm
Lots of info on this very subject unfortunately and it appears Hyundai and KIA do not have a solution..some reading for investigation

New car frustration
http://forums.moneysavingexpert.com/showthread.php?s=db377fb0c680ec90109aff84199d5689&t=2754344&page=2#topofpage


TOPIC: WHITE/LIGHT GREY SMOKE ON START UP  (READ 3579 TIMES)


Back to Top
Sponsored Links


Back to Top
gtd2000 View Drop Down
Senior Member
Senior Member


Joined: 27 Oct 2011
Location: Galashiels
Status: Offline
Points: 908
Post Options Post Options   Thanks (0) Thanks(0)   Quote gtd2000 Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jul 2018 at 2:02pm
Lots of fed up i30 owners out there.

This is one suggestion: "I have an i30 wagon. This happened to me. It's your glow plug fuse"
Back to Top
Kiahero View Drop Down
Newbie
Newbie


Joined: 28 Jun 2018
Location: Malta
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kiahero Quote  Post ReplyReply Direct Link To This Post Posted: 18 Jul 2018 at 9:43am
Morning, sorry for the late reply but I was a bit busy lately. Glow plugs were replaced but not the fuse. I believe this is something dependent on ambient temperature since in summer the problem disappears completely only to return in November as soon as the temperatures start falling below 20c. Do you have any idea how to contact Kia Europe technical division, I cannot find any e-mails or address.thanks
Back to Top
gtd2000 View Drop Down
Senior Member
Senior Member


Joined: 27 Oct 2011
Location: Galashiels
Status: Offline
Points: 908
Post Options Post Options   Thanks (0) Thanks(0)   Quote gtd2000 Quote  Post ReplyReply Direct Link To This Post Posted: 18 Jul 2018 at 11:34am
Originally posted by Kiahero Kiahero wrote:

Morning, sorry for the late reply but I was a bit busy lately. Glow plugs were replaced but not the fuse. I believe this is something dependent on ambient temperature since in summer the problem disappears completely only to return in November as soon as the temperatures start falling below 20c. Do you have any idea how to contact Kia Europe technical division, I cannot find any e-mails or address.thanks

I'd get in touch with your local KIA dealer to provide this contact information as a first step. Or the local KIA Customer Service at +356 2269 2123


Edited by gtd2000 - 18 Jul 2018 at 11:36am
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.06
Copyright ©2001-2016 Web Wiz Ltd.